Release #9867

Release #9397: gCube Release 4.7.0

Release #9604: org.gcube.portlet-user.4-7-0

org.gcube.portlets-user.workspace-portlet-tree.6-18-0

Added by Francesco Mangiacrapa almost 2 years ago. Updated almost 2 years ago.

Status:ReleasedStart date:Sep 29, 2017
Priority:ImmediateDue date:
Assignee:Francesco Mangiacrapa
Category:portlets-user
Sprint:Release 4.7.0
Wiki Updates:Unneeded Version Control System:
Type:Common Apps Building System:
Milestones:
Duration:

Related issues

Related to gCube - Feature #9760: WS-Thredds synch folder integration Closed Sep 22, 2017

History

#1 Updated by Francesco Mangiacrapa almost 2 years ago

  • Type changed from Enabling to Common Apps

#2 Updated by Francesco Mangiacrapa almost 2 years ago

  • Related to Feature #9760: WS-Thredds synch folder integration added

#3 Updated by Francesco Mangiacrapa almost 2 years ago

  • Status changed from New to Available

#4 Updated by Maria Di Girolamo almost 2 years ago

  • Status changed from Available to Under Integration

#5 Updated by Maria Di Girolamo almost 2 years ago

Build fails due to missing a new portlet added last Friday : #9868. It's necessary created before the portlets-user.ws-thredds in the ETICS.

#6 Updated by Maria Di Girolamo almost 2 years ago

  • Priority changed from Normal to Immediate
  • Status changed from Under Integration to Build Issue

The last nightly build (http://eticsbuild2.research-infrastructures.eu/BuildReport/bdownload/AllBuilds/org.gcube.4-7-0/BUILD_17/reports/reportModuleDetail-org.gcube.portlets-user.workspace-portlet-tree.html) fails.
The failure seems due to the wrong declaration of the ws-thredds dependency in the pom file:
Failed to collect dependencies at org.gcube.portlets.user:ws-thredds:jar:[0.0.1-SNAPSHOT,1.0.0-SNAPSHOT): No versions available for org.gcube.portlets.user:ws-thredds:jar:[0.0.1-SNAPSHOT,1.0.0-SNAPSHOT) within specified range -> [Help 1]
[ERROR] ....

The possible solution should be declare the actual version of the ws-thredds: 0.0.1-SNAPSHOT

Please are welcome any other possible solution to solve the issue.

Thank you,
Maria.

#7 Updated by Francesco Mangiacrapa almost 2 years ago

@fabio.sinibaldi@isti.cnr.it, @mariaantonietta.digirolamo@eng.it I think that the build http://eticsbuild2.research-infrastructures.eu/BuildReport/bdownload/AllBuilds/org.gcube.4-7-0/BUILD_17/reports/reportModuleDetail-org.gcube.portlets-user.workspace-portlet-tree.html is failed due to the wrong dependency declared in the 'workspace-portlet-tree' pom for the component 'ws-thredds'.

In particular, in the 'workspace-portlet-tree' pom the dependency is:

<groupId>org.gcube.portlets.user</groupId>
<artifactId>ws-thredds</artifactId>
<version>[0.0.1-SNAPSHOT, 1.0.0-SNAPSHOT)</version>
<scope>compile</scope>

But the component 'ws-thredds' is released with the following one:

<groupId>org.gcube.portlets-user</groupId>
<artifactId>ws-thredds</artifactId>
<version>0.0.1-4.7.0-154749
</version>
<name>ws-thredds</name>

The groupids are different. 'org.gcube.portlets.user' vs 'org.gcube.portlets-user'

Let me know either I must change such import/declaration in the in the workspace-portlet-tree pom (at 'org.gcube.portlets-user') or @fabio.sinibaldi@isti.cnr.it must change the groupid of the ws-thredds (at 'org.gcube.portlets.user')

#8 Updated by Maria Di Girolamo almost 2 years ago

Hi @francesco.mangiacrapa@isti.cnr.it , thank you.

The correct group id is
org.gcube.portlets.user

so please update @fabio.sinibaldi@isti.cnr.it coud you update the ws-thredds pom ?

thank you Maria.

#9 Updated by Fabio Sinibaldi almost 2 years ago

Fixed pom is at revision 154764. Still don't have update rights on the etics configuration, though. @gabriele.giammatteo@eng.it can you assign me the component org.gcube.portlets-user.ws-thredds?
Meanwhile, @mariaantonietta.digirolamo@eng.it would you be so kind to update the configuration and launch a remote build?
Thanks in advance.

#10 Updated by Gabriele Giammatteo almost 2 years ago

Fabio Sinibaldi wrote:

Fixed pom is at revision 154764. Still don't have update rights on the etics configuration, though. @gabriele.giammatteo@eng.it can you assign me the component org.gcube.portlets-user.ws-thredds?
Meanwhile, @mariaantonietta.digirolamo@eng.it would you be so kind to update the configuration and launch a remote build?
Thanks in advance.

Done

#11 Updated by Maria Di Girolamo almost 2 years ago

  • Status changed from Build Issue to Under Integration

I repeated twice the local build and the result is Success.

#12 Updated by Maria Di Girolamo almost 2 years ago

  • Status changed from Under Integration to Released

Also available in: Atom PDF