Bug #9309

Problem corectly registering VREs after container restart

Added by Kostas Kakaletris over 2 years ago. Updated over 2 years ago.

Status:RejectedStart date:Jul 18, 2017
Priority:HighDue date:
Assignee:Lucio Lelii% Done:

0%

Category:information-system
Sprint:zz - Resource Publication
Milestones:
Duration:

Description

We have problem registering correctly multiple VREs running in a container to IS.

To be more precisely, we register correctly multiple VREs under a container that is running more than one service (maybe under multiple VOs too) at the first time but if update a service and restart the container or if we add new VREs then probably the services will not be registered correctly.

In that case the host profile will be showing all the VREs correctly but the service profile will be showing just one VRE (or at least not all the correct VREs.

An example is on dl20.di.uoa.gr (PreProduction) that is having two services in one container belonging to 2 VREs. I was cleaning the container state before when upgrading and @roberto.cirillo@isti.cnr.it suggested me that I should just clear state when changing the container.xml only. Now I just updated the one of the two service following this procedure : Stopped service -> checked monitor that was stopped -> deleted the war and all folders related to the service that I was updating (simulefish), added the new war and started the service and the problem occurred again (after 2 more times that happened in the morning in the same container/services)

It is important to solve the issue and not just fix it to the specific installation, because we start having services running on multiple VREs and probably VOs on production. In such issues this problem is causing big unexpected downtime when we jsut want to add a new VRE.

I believe that is related that if you stop and clean a container that is having multiple VREs then most probably the service will not be registered correctly too.Not correct to do clean-state but still I think is an issue and related to the above one.

Kind Regards,
Kostas

History

#1 Updated by Kostas Kakaletris over 2 years ago

We have problem registering correctly multiple VREs running in a container to IS.

To be more precisely, we register correctly multiple VREs under a container that is running more than one service (maybe under multiple VOs too) at the first time but if update a service and restart the container or if we add new VREs then probably the services will not be registered correctly.

In that case the host profile will be showing all the VREs correctly but the service profile will be showing just one VRE (or at least not all the correct VREs.

An example is on dl20.di.uoa.gr (PreProduction) that is having two services in one container belonging to 2 VREs. We used tokens at the beginning and when the problem first occurred @roberto.cirillo@isti.cnr.it added the services manual to the corresponding VREs through monitoring.
When I upgraded the services I cleaned the container state before and as Roberto stated to me this caused the registration to be deleted too so informed me to not do it in such cases.
Mean while I added again the tokens to the container.xml but the VREs weren't registered. @lucio.lelii@isti.cnr.it or @roberto.cirillo@isti.cnr.it fixed it and the services were shown correctly again (the container.xml still having the tokens)
Now I just updated the one of the two service following this procedure : Stopped service -> checked monitor that was stopped -> deleted the war and all folders related to the service that I was updating (simulefish), added the new war and started the service and the problem occurred again

It is important to solve the issue and not just fix it to the specific installation, because we start having services running on multiple VREs and probably VOs on production. In such issues this problem is causing big unexpected downtime when we jsut want to add a new VRE.

Kind Regards,
Kostas

#2 Updated by Roberto Cirillo over 2 years ago

Dear @k.kakaletris@cite.gr I had already opened a ticket for this problem and you was set as watcher: #9118

#3 Updated by Kostas Kakaletris over 2 years ago

  • Status changed from New to Rejected

closed as duplicate of ticket #9118.

Also available in: Atom PDF