Task #9074

Move of BlueEconomy companies VREs from gCubeApps Virtual Organisation to FARM

Added by Massimiliano Assante over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:Jun 27, 2017
Priority:HighDue date:Jun 30, 2017
Assignee:Gerasimos Antzoulatos% Done:

100%

Category:-
Sprint:WP06
Infrastructure:
Milestones:
Duration: 4

Description

Dear Gerasimos and Denis,

we plan to move the 3 VREs (Forkys, Ellenika and Alieia from the current Virtual Organisation to the FARM. This is to better distribute the work load of the infrastructure.

In practice this means that the VRE name (and groupid) will be maintained but the infrastructure scope (aka context) would change from e.g.

  • /d4science.research-infrastructures.eu/gCubeApps/EllinikaPsariaVRE to /d4science.research-infrastructures.eu/FARM/EllinikaPsariaVRE

Before doing this we would need to know if the database serving the VREs (or any other WP6 service involved) uses the infrastructure scope (aka context) in any way that would make the VRE stop working.

Note that the content of the Workspace will remain as is, and the services deployed in the new scopes. So my concerns are about the DB used an or any other "stateful" storage you may use in these VREs.


Related issues

Related to gCube - Bug #9118: Smartgears container: service run only on one scope but t... Closed Jun 30, 2017

History

#1 Updated by Denis Pyriochos over 2 years ago

Dear @massimiliano.assante@isti.cnr.it we are using the full scope name in order to identify each aqua farm in the database. As soon as you move them to the new infrastructure we should update their records. So please provide us with the new full scope names and we will do the database update.

#2 Updated by Massimiliano Assante over 2 years ago

  • Status changed from New to In Progress

Thanks Denis, I think we should do this in a coordinate manner.

First I suggest to wait for the WP6 Services to be fully functional in the 2 new VRES (Markellos and Stratos), then we will perform the move in coordination. When would it be a suitable time for you this week?

#3 Updated by Denis Pyriochos over 2 years ago

Unavailable on Friday, from the afternoon on. Schedule on any other time :) and notify me.

#4 Updated by Massimiliano Assante over 2 years ago

The 3 VREs running on the following scopes, respectively:

  • /d4science.research-infrastructures.eu/gCubeApps/EllinikaPsariaVRE
  • /d4science.research-infrastructures.eu/gCubeApps/ForkysVRE
  • /d4science.research-infrastructures.eu/gCubeApps/AlieiaVRE

Are going to be moved under FARM, the new scopes for the 3 VREs will be the following:

  • /d4science.research-infrastructures.eu/FARM/EllinikaPsariaVRE
  • /d4science.research-infrastructures.eu/FARM/ForkysVRE
  • /d4science.research-infrastructures.eu/FARM/AlieiaVRE

@denispyr@i2s.gr I suggest to do this Tomorrow, Friday 30th at 11.30 CEST You will need to apply the required changes in the DB while @k.kakaletris@cite.gr to make available the required services running on gCubeApps on FARM

is the plan ok with both of you?

#5 Updated by Denis Pyriochos over 2 years ago

Fine by me.

#6 Updated by Kostas Kakaletris over 2 years ago

I think that it would be more convenient to do it at the beginning of the day and not in the middle of it (11:30 CEST is 12:30 in Greece). Maybe it is possible to do it earlier, i.e. 09:00 or 09:30 CEST ?

#7 Updated by Denis Pyriochos over 2 years ago

So, is it morning or noon?

#8 Updated by Kostas Kakaletris over 2 years ago

@massimiliano.assante@isti.cnr.it is it OK to do it at 09:00 CEST or you need to do changes on your side too and it is not convenient for you?
@roberto.cirillo@isti.cnr.it after fixing the time are you going to send a notification for downtime on this VREs? (I believe a one hour downtime is sufficient for changing and testing, is that correct @denispyr@i2s.gr ?)

#9 Updated by Denis Pyriochos over 2 years ago

Sufficient enough, on my side.

#10 Updated by Massimiliano Assante over 2 years ago

Kostas unfortunately i have another commitment early morning. Since is not a very urgent task we can postpone it to the next week, Monday 9.30 CEST? Downtime until 10.30

#11 Updated by Kostas Kakaletris over 2 years ago

I believe that it will take us only 15-30 min to make the change and the checks, so even though not very convenient, lets do it tomorrow 30/6 at 11:30 CEST as you suggested at the beginning, so that we close it.

#12 Updated by Massimiliano Assante over 2 years ago

Ok I'm going to send a downtime announcement on the 3 VREs

#13 Updated by Massimiliano Assante over 2 years ago

  • % Done changed from 0 to 30

#14 Updated by Massimiliano Assante over 2 years ago

  • % Done changed from 30 to 60

#15 Updated by Massimiliano Assante over 2 years ago

  • % Done changed from 60 to 90

The 3 BlueEconomy companies VREs have been moved from gCubeApps Virtual Organisation to FARM. We are finalising the work adding the necessary missing resources

#16 Updated by Massimiliano Assante over 2 years ago

ServiceEndpoint for Database SimulFishGrowth is available in the 3 scopes as well as the Dataminer Service with the required algorithm

#17 Updated by Denis Pyriochos over 2 years ago

Database updated to reflect the new FARM scopes.

Only AquacultureTrainingLab \d4science.research-infrastructures.eu\gCubeApps\AquacultureTrainingLab entries are pointing to the old scope

#18 Updated by Kostas Kakaletris over 2 years ago

The service is started but not getting the VREs correct on all services. ie I see on IS that host is shown to be under all declared VREs but simulefish endpoint is shown under on;y the first one and not working correctly.
No errors in tomcat.
In Smatgears I see the following
14:43:13.851 [localhost-startStop-1] WARN Bootstrap: WELD-001208: Error when validating file:/home/gcube/apache-tomcat-7.0.72/webapps/data-transfer-service/WEB-INF/classes/META-INF/beans.xml@4 against xsd. cvc-complex-type.4: Attribute 'bean-discovery-mode' must appear on element 'beans'.
14:43:14.095 [localhost-startStop-1] WARN Interceptor: WELD-001700: Interceptor annotation class javax.ejb.PostActivate not found, interception based on it is not enabled
14:43:14.096 [localhost-startStop-1] WARN Interceptor: WELD-001700: Interceptor annotation class javax.ejb.PrePassivate not found, interception based on it is not enabled
14:43:14.399 [localhost-startStop-1] WARN Event: WELD-000411: Observer method [BackedAnnotatedMethod] private org.glassfish.jersey.gf.cdi.internal.CdiComponentProvider.processAnnotatedType(@Observes ProcessAnnotatedType) receives events for all annotated types. Consider restricting events using @WithAnnotations or a generic type with bounds.
14:43:44.182 [localhost-startStop-1] ERROR DatabaseFilter: DatabaseFilter ctor : test error

I will try to add VREs to the service one by one to see if the problem is because of a specific VRE

#19 Updated by Roberto Cirillo over 2 years ago

Have you cleaned the container state before the restart?

#20 Updated by Roberto Cirillo over 2 years ago

Some service on dewn05 were running only on a single scope but the container was running on more than one scope. This is not possible, I guess it could be a smartgears bug and I'm going to open a ticket about that.
I've resolved the problem on dewn05 adding the VO scope on the container and adding manually the VRE scopes on the GCoreEndpoint resources of the services. Now, the services are running on all the scope as expected.

#21 Updated by Denis Pyriochos over 2 years ago

All five farm VREs, old and new, functioning properly. Nothing more to do.

#22 Updated by Massimiliano Assante over 2 years ago

  • % Done changed from 90 to 100
  • Status changed from In Progress to Closed

Great, thank you everyone for your efforts.

#23 Updated by Roberto Cirillo over 2 years ago

  • Related to Bug #9118: Smartgears container: service run only on one scope but the container run on multiple scopes added

Also available in: Atom PDF