Task #8608

Release #8211: gCube Release 4.5.0

Release #8420: data-access-4.5.0

streams-2.0.2-1 (locked) to update

Added by Maria Di Girolamo about 2 years ago. Updated about 2 years ago.

Status:RejectedStart date:May 16, 2017
Priority:NormalDue date:
Assignee:Lucio Lelii% Done:

0%

Category:data-access
Sprint:Release 4.5.0
Milestones:
Duration:

Description

The last nightly build fails: http://eticsbuild2.research-infrastructures.eu/BuildReport/bdownload/AllBuilds/org.gcube.4-5-0/BUILD_13/reports/reportModuleDetail-streams.html.

The solution should be force to the Java7 as suggested in the wiki documentation: https://wiki.gcube-system.org/gcube/Developing_gCube_Maven_Components#Java_Version.

This issue is blocking 30 components

As reported in ETICS Issue (https://etics.esl.eng.it/etics-gui/), I'm going to assign the ticket to you. Please if you aren't the responsible could you re-assign the ticket?

PS: I try to forse Java7 during the excution of the ETICS Build and the result is ok : http://etics.esl.eng.it/etics-repository-ws//reports/id/ef77a08d-45f7-4893-b78a-97e63b49da73/centos6.9_x86_64_gcc447/-/reports/build-status.xml.

History

#1 Updated by Maria Di Girolamo about 2 years ago

  • Parent task set to #8420

#2 Updated by Gabriele Giammatteo about 2 years ago

I do not think this can be (only) related to Java 8... in fact in B12 the build was ok [1].

In addition, please note that this is an error in the tests, not a compilation error. If we find that it is related to Java 8, we should carefully investigate the cause, because it could indicate misbehaviours at runtime.

[1] http://eticsbuild2.research-infrastructures.eu/BuildReport/bdownload/AllBuilds/org.gcube.4-5-0/BUILD_12/reports/reportModuleDetail-streams.html

#3 Updated by Maria Di Girolamo about 2 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF