Release #8519

Release #8211: gCube Release 4.5.0

Release #8510: org.gcube.information-system.4-5-0

resource-registry.1-4-0

Added by Luca Frosini over 2 years ago. Updated over 2 years ago.

Status:ReleasedStart date:May 12, 2017
Priority:NormalDue date:
Assignee:Luca Frosini
Category:information-system
Sprint:gCube Release 4.5.0
Wiki Updates:Unneeded Version Control System:
Type:Common Apps Building System:
Milestones:
Duration:

History

#1 Updated by Luca Frosini over 2 years ago

  • Status changed from New to Available

#2 Updated by Luca Frosini over 2 years ago

  • Status changed from Available to Under Integration

#3 Updated by Maria Di Girolamo over 2 years ago

  • Status changed from Under Integration to Build Issue

The last build fails due to the Compilation Error : http://eticsbuild2.research-infrastructures.eu/BuildReport/bdownload/AllBuilds/org.gcube.4-5-0/BUILD_12/reports/reportModuleDetail-org.gcube.information-system.resource-registry.html
<<

[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] /home/gbuilder/workspace.org.gcube.4-5-0/org.gcube.information-system.resource-registry/src/test/java/org/gcube/informationsystem/resourceregistry/er/SmartgearResourcesTest.java:[244,128] incompatible types: inferred type does not conform to equality constraint(s)
inferred: org.gcube.informationsystem.model.relation.ConsistsOf<? extends org.gcube.informationsystem.model.entity.Resource,? extends org.gcube.informationsystem.model.entity.Facet>

Please, could you check the error?

#4 Updated by Luca Frosini over 2 years ago

Hi @mariaantonietta.digirolamo@eng.it I really don't understand this issue. It builds locally. anyway I try a fix.

#6 Updated by Luca Frosini over 2 years ago

  • Status changed from Build Issue to Under Integration

Now it seems solved

http://etics.esl.eng.it/etics-repository-ws/reports/id/889c6506-983a-43a5-be7b-08b9debfa56d/centos6.9_x86_64_gcc447/-/reports/build-status.

@gabriele.giammatteo@eng.it @mariaantonietta.digirolamo@eng.it with java version "1.8.0_131" my code didn't had such issues. Please take in account to upgrade the JDK. Maybe it is better when the release is closed.

#7 Updated by Gabriele Giammatteo over 2 years ago

thanks for the feedback. We will try to understand if the version of Java is the problem and will upgrade it in the integration environment

#8 Updated by Maria Di Girolamo over 2 years ago

  • Status changed from Under Integration to Released

Also available in: Atom PDF