Feature #8242

Enhance VRE Folder hook to also create Share LaTex user on user add to VRE

Added by Massimiliano Assante over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:Apr 21, 2017
Priority:HighDue date:Apr 28, 2017
Assignee:Lucio Lelii% Done:

100%

Category:-
Sprint:gCube Release 4.4.0
Milestones:
Duration: 6

Description

The hook should call the ShareLatex connector (if present in the VRE) doing a connect and a disconnect


Related issues

Related to gCube - Release #8765: data-access.sharelatex-connector.1.0.2 Released May 25, 2017

History

#1 Updated by Massimiliano Assante over 2 years ago

  • Due date set to Apr 28, 2017

#2 Updated by Massimiliano Assante over 2 years ago

  • Status changed from New to In Progress

#3 Updated by Massimiliano Assante over 2 years ago

  • % Done changed from 0 to 50

#5 Updated by Massimiliano Assante over 2 years ago

  • Assignee changed from Massimiliano Assante to Lucio Lelii

After verifying with @lucio.lelii@isti.cnr.it it seems that the "connect" to the ShareLatex connector is correctly performed and the user is created, however it is not enough because when the "just added" user login to ShareLatex it seems is still the first time and no invitations appear.

#6 Updated by Pasquale Pagano over 2 years ago

  • Priority changed from Normal to High

#7 Updated by Lucio Lelii over 2 years ago

The problem is that sharelatex, to understand if the user is new, checks the number of projects he has created. The solution is to create a fake project at user creation.

#9 Updated by Massimiliano Assante over 2 years ago

  • % Done changed from 50 to 90

Lucio has been able to create a fake project at user creation, so now if the user access the first time and she was invited the invite is correctly displayed. We tested this on dev with few users. For this to work for existing VRE users , they have to be removed first and added back. https://next.d4science.org/group/nextnext/share-latext

Setting at 90% as the fake project created is missing something as it does not compile. Not a big issue though it should be fixed. Next step is to work on #8270. Related to this I was wondering that if we are able to intercept the invitation we don't need this hook anymore, we could call both the connector and the social service at once.

#10 Updated by Lucio Lelii over 2 years ago

  • % Done changed from 90 to 100
  • Assignee changed from Lucio Lelii to Massimiliano Assante
  • Status changed from In Progress to Feedback

now the created project compiles.

#11 Updated by Massimiliano Assante over 2 years ago

  • Assignee changed from Massimiliano Assante to Lucio Lelii
  • Status changed from Feedback to In Progress

Are we releasing this in gCube 4.5 or in 4.6? @lucio.lelii@isti.cnr.it please create a release ticket (if not already) and relate it to this one.

#12 Updated by Lucio Lelii over 2 years ago

  • Related to Release #8765: data-access.sharelatex-connector.1.0.2 added

#13 Updated by Lucio Lelii over 2 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF