Task #7169

Install AAPS production GeoServer with spatialite plugin & DataTransfer service

Added by Fabio Sinibaldi over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:Feb 20, 2017
Priority:UrgentDue date:
Assignee:_InfraScience Systems Engineer% Done:

100%

Category:Default
Sprint:WP07
Infrastructure:
Milestones:
Duration:

Description

Please configure GeoServer production instances in order to reproduce achievements from ticket #5828 in particular :

  • spatialite plugin deployment and configuration
  • data-transfer-service deployment and configuration

Related issues

Related to BlueBRIDGE - Project Activity #5828: Evaluate feasibly to publish Spatialite layer in GeoServe... Closed Dec 02, 2016
Related to BlueBRIDGE - Support #7155: How to add AquacultureAtlasGeneration scope with AAPS Geo... Rejected Feb 17, 2017

History

#1 Updated by Emmanuel Blondel over 2 years ago

  • Priority changed from Normal to Urgent

It is not on all production GeoServerS, the request is only for a specific Geoserver instance for AAPS VRE, version of Geoserver much more recent (one of the recent releases). And of course, AAPS VRE activity cannot wait for you to migrate all your geoservers to latests and enable spatialite on them (for which probably the extension is not required since not requested until now).

Please report to CLS once done, as they will be the publishers on this GeoServer AAPS @nlongepe@cls.fr @mgoacolou@cls.fr

Thanks in advance

#2 Updated by Emmanuel Blondel over 2 years ago

  • Subject changed from Enable spatialite plugin and DataTransfer service on production GeoServers to Install AAPS production GeoServer with spatialite plugin & DataTransfer service

#3 Updated by Emmanuel Blondel over 2 years ago

  • Related to Project Activity #5828: Evaluate feasibly to publish Spatialite layer in GeoServer with existing tools added

#4 Updated by Pasquale Pagano over 2 years ago

  • Related to Support #7155: How to add AquacultureAtlasGeneration scope with AAPS Geoserver added

#5 Updated by Andrea Dell'Amico over 2 years ago

  • Status changed from New to In Progress

#6 Updated by Andrea Dell'Amico over 2 years ago

@fabio.sinibaldi@isti.cnr.it can you give me a list of scopes to configure the smartgears part?

#7 Updated by Andrea Dell'Amico over 2 years ago

Hostname and IP address are going to be: geoserver1-p-spatial.d4science.org 146.48.122.211

#8 Updated by Fabio Sinibaldi over 2 years ago

AAPS here should stand for AquacultureAtlasGeneration VRE, full name : /d4science.research-infrastructures.eu/gCubeApps/AquacultureAtlasGeneration

#9 Updated by Andrea Dell'Amico over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Feedback

The server is ready. Let me know if it's OK.

#10 Updated by Andrea Dell'Amico over 2 years ago

  • Status changed from Feedback to Closed

#11 Updated by Emmanuel Blondel over 2 years ago

  • Status changed from Closed to In Progress

Apologies @andrea.dellamico@isti.cnr.it i missed that ticket. Can you tell me what is the URL of the new Geoserver production? As soon you tell me i will test this
I've tried https://geoserver1-p-spatial.d4science.org/geoserver/ but it doesn't work.

#12 Updated by Emmanuel Blondel over 2 years ago

  • Status changed from In Progress to Feedback

#13 Updated by Andrea Dell'Amico over 2 years ago

@fabio.sinibaldi@isti.cnr.it the geoserver app starts correctly, but any invocation fails with

2017-03-09 11:32:32,006 [catalina-exec-1] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/geoserver].[dispatcher]- Servlet.service() for servlet [dispatcher] in context with path [/geoserver] threw exception
java.lang.StringIndexOutOfBoundsException: String index out of range: -1
        at java.lang.String.substring(String.java:1967)
        at org.gcube.smartgears.managers.RequestManager.getPipelineWithExcluded(RequestManager.java:137)
        at org.gcube.smartgears.managers.RequestManager.doFilter(RequestManager.java:66)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:220)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)
        at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:501)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:98)
        at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:950)
        at org.apache.catalina.valves.RemoteIpValve.invoke(RemoteIpValve.java:683)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:408)
        at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1041)
        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:607)
        at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:313)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)

Any clues? The installation is identical to the dev one.

#14 Updated by Fabio Sinibaldi over 2 years ago

It seems to be caused by smartgears handling exclusion.
I couldn't find any differences between dev/prod gcube-app.xml files for geoserver app.
@lucio.lelii@isti.cnr.it any clues?

#15 Updated by Fabio Sinibaldi over 2 years ago

We identified the issue in the gcube-app.xml.
Current SmartGears distribution doesn't support "*" exclusion rule but only "/*". The fix was deployed on geoserver-spatial-dev and released in 4.3, so that's why it didn't work here in production.

Fixed the gcube-app.xml, now geoserver webapp is accessible.

#16 Updated by Emmanuel Blondel over 2 years ago

  • Status changed from Feedback to Closed

Great, many thanks for your prompt actions! (and again apologies for this late ticket feedback)

Also available in: Atom PDF