Feature #6631

Update in Logged-in via Google, LinkedIn button behaviour

Added by Massimiliano Assante over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:Jan 26, 2017
Priority:HighDue date:Feb 03, 2017
Assignee:Panagiota Koltsida% Done:

100%

Category:portal
Sprint:Login portlet features
Milestones:
Duration: 7

Description

Logged-in via Google, LinkedIn button behaviour should be enhanced.

We are receiving quite a lot of feedback from existing users (accounts). The problem is that they think they can login with their other Emails account but the result is a new account creation instead.

Probably we should split the functionalities in 2 buttons (like others services do):

  • Sign up: only create the user account if not existent (here it would be nice to import user avatar if present)
  • Sign in: authorise the user account (does not create an account if the email does not exist in the LR DB) perhaps should say if you want to link your e.g. gmail account go to your profile bla bla bla

What do you think?


Related issues

Related to gCube - Release #8824: org.gcube.portal.login-hook.1-3-0 Released Jun 02, 2017 Jul 06, 2017
Related to gCube - Release #8825: org.gcube.portal.google-login-hook.1-2-0 Released Jun 02, 2017 Jul 06, 2017
Related to gCube - Release #8826: org.gcube.portal.linkedin-login-hook.1-2-0 Released Jun 02, 2017 Jul 06, 2017

History

#1 Updated by Panagiota Koltsida over 2 years ago

It is true that users expect some "magic", like the system can link something it does not know yet, and this means we should indeed improve the behavior of the login options.
I'm not sure on how much work it is required and how much effort we can give on this. We will investigate it and come back again. In the meanwhile maybe we could make some minor enhancements like adding an informative message for the login options.

A message like "for existing users declared e-mail accounts can be used to sign-in, otherwise a new user account will be created automatically"

#2 Updated by Panagiota Koltsida over 2 years ago

In this release I would like to add the "informative" message under the social login buttons to inform user about what is supported.
Since this is part of the login-hook, @massimiliano.assante@isti.cnr.it have you made any changes in this hook in 4.3? Should I add the message or will you do it?

#3 Updated by Massimiliano Assante over 2 years ago

hi Giota, the login-hook was moved to gCube SVN Trunk (trunk/portal/liferay62-plugins/login-hook) and it was released in gCube 4.3 to support oAuth2. So if you want to add the message please use this trunk

#5 Updated by Massimiliano Assante over 2 years ago

  • Priority changed from Normal to High

#6 Updated by Panagiota Koltsida over 2 years ago

Since this is user's strange behavior I will change the sign-in to sign-up now and I will add the informative message which I thought I had done it.
Probably forgot to commit and release.

#7 Updated by Panagiota Koltsida over 2 years ago

I have updated 3 components.
I have deployed them on https://next.d4science.org/home

If you agree with the informative text then I will create release tickets for them

#8 Updated by Panagiota Koltsida over 2 years ago

  • % Done changed from 0 to 90
  • Status changed from New to In Progress

#9 Updated by Panagiota Koltsida over 2 years ago

  • % Done changed from 90 to 100
  • Status changed from In Progress to Closed

#10 Updated by Panagiota Koltsida over 2 years ago

  • Related to Release #8824: org.gcube.portal.login-hook.1-3-0 added

#11 Updated by Panagiota Koltsida over 2 years ago

  • Related to Release #8825: org.gcube.portal.google-login-hook.1-2-0 added

#12 Updated by Panagiota Koltsida over 2 years ago

  • Related to Release #8826: org.gcube.portal.linkedin-login-hook.1-2-0 added

Also available in: Atom PDF