Task #6314

VREModeler: not all the resources requested are added in creation phase

Added by Roberto Cirillo almost 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:Jan 10, 2017
Priority:NormalDue date:
Assignee:Roberto Cirillo% Done:

100%

Category:vre-management
Sprint:zz - Improve VRE Creation
Milestones:
Duration:

Description

When a new VRE is created not all the resources requested in definition phase are correctly added.
Please, could you check?


Related issues

Blocked by D4Science Infrastructure - Task #6319: node4.d.d4science.research-infrastructures.eu: upgrade OS Closed Jan 10, 2017

History

#1 Updated by Roberto Cirillo almost 3 years ago

  • Related to Task #6319: node4.d.d4science.research-infrastructures.eu: upgrade OS added

#2 Updated by Roberto Cirillo almost 3 years ago

  • Related to deleted (Task #6319: node4.d.d4science.research-infrastructures.eu: upgrade OS)

#3 Updated by Roberto Cirillo almost 3 years ago

  • Blocked by Task #6319: node4.d.d4science.research-infrastructures.eu: upgrade OS added

#4 Updated by Roberto Cirillo almost 3 years ago

  • Assignee changed from Lucio Lelii to Roberto Cirillo

#5 Updated by Roberto Cirillo almost 3 years ago

  • Status changed from New to In Progress

Several resources not present in the Functionalities Model seems to be automatically added in Creation phase:

<SecondaryType>PresentationXSLT</SecondaryType>
<Name>GenericXSLT</Name>

<SecondaryType>Schemas Searchable Fields</SecondaryType>
<Name>MetadataSchemaInfo</Name>

<SecondaryType>PresentationXSLT</SecondaryType>
<Name>TitleXSLT</Name>


 <SecondaryType>Schemas Searchable Fields</SecondaryType>
 <Name>MetadataSchemaInfo</Name>


<SecondaryType>UserProfile</SecondaryType>
<Name>DefaultUserProfile</Name>


<SecondaryType>PresentationXSLT</SecondaryType>
<Name>BrowseFieldXSLT</Name>

 <SecondaryType>Schemas Searchable Fields</SecondaryType>
 <Name>MetadataSchemaInfo</Name>


 <SecondaryType>MetadataXSLT</SecondaryType>       
 <Name>MetadataXSLT-|-Epidoc-|-default</Name>


<SecondaryType>UserProfile</SecondaryType>        
<Name>DefaultUserProfile</Name>

I don't know why. I'm going to do further analysis.

#6 Updated by Roberto Cirillo almost 3 years ago

  • % Done changed from 0 to 60

I've found the issue.
The problem was due to a bad ServiceContext scope in the ResourceManager service when it performs a sequence of addScope operations.
The first addScope goes well but from second operation to the last operation the ServiceContext scope is set to root scope rather than VO scope.
For this reason only a resource is correctly added when a new VRE is created. This is an extracted of log:

2017-01-13 12:21:13,512 DEBUG resources.ScopedAnyResource [ServiceThread-60,debug:66] ScopedAnyResource: republish the resource bdaccb35-7f27-45a6-8ca9-11d467cb9233 with scope added /gcube/devsec/TestCreation13with GCubeScope: /gcube/devsec in context org.gcube.vremanagement.resourcemanager.impl.contexts.ServiceContext@1c059ea
2017-01-13 12:21:13,514 TRACE resources.RegistryResourcePublisher [ServiceThread-60,trace:82] RegistryResourcePublisher: Trying to update resource with ID=bdaccb35-7f27-45a6-8ca9-11d467cb9233 in scope /gcube/devsec
2017-01-13 12:21:13,515 DEBUG impl.DefaultScopeProvider [ServiceThread-60,set:38] setting scope /gcube/devsec in thread 93
2017-01-13 12:21:13,527 INFO  resources.ISRegistryServiceUpdaterHandler [ServiceThread-60,info:78] ISRegistryServiceUpdaterHandler: using cached instance of ISRegistryServiceHandler@ http://node3.d.d4science.research-infrastructures.eu:8080/wsrf/services/gcube/informationsystem/registry/ResourceRegistration
2017-01-13 12:21:13,530 TRACE resources.ISRegistryServiceUpdaterHandler [ServiceThread-60,trace:82] ISRegistryServiceUpdaterHandler: Connecting to the IS-Registry instance located at http://node3.d.d4science.research-infrastructures.eu:8080/wsrf/services/gcube/informationsystem/registry/ResourceRegistration...
2017-01-13 12:21:13,531 DEBUG impl.DefaultScopeProvider [ServiceThread-60,set:38] setting scope /gcube/devsec in thread 93
2017-01-13 12:21:13,534 DEBUG impl.DefaultScopeProvider [ServiceThread-60,set:38] setting scope /gcube/devsec in thread 93
2017-01-13 12:21:13,576 TRACE resources.UpdateResourceHandler [ServiceThread-60,trace:82] UpdateResourceHandler: Resource with ID=bdaccb35-7f27-45a6-8ca9-11d467cb9233 Successfully updated
2017-01-13 12:21:13,578 DEBUG resources.ScopedAnyResource [ServiceThread-60,debug:66] ScopedAnyResource: ServiceContext scope: /gcube/devsec
2017-01-13 12:21:13,579 DEBUG resources.ScopedAnyResource [ServiceThread-60,debug:66] ScopedAnyResource:  published also on: /gcube
2017-01-13 12:21:13,582 TRACE resources.RegistryResourcePublisher [ServiceThread-60,trace:82] RegistryResourcePublisher: Trying to update resource with ID=bdaccb35-7f27-45a6-8ca9-11d467cb9233 in scope /gcube
2017-01-13 12:21:13,583 DEBUG impl.DefaultScopeProvider [ServiceThread-60,set:38] setting scope /gcube in thread 93
2017-01-13 12:21:13,593 INFO  resources.ISRegistryServiceUpdaterHandler [ServiceThread-60,info:78] ISRegistryServiceUpdaterHandler: using cached instance of ISRegistryServiceHandler@ http://node1.d.d4science.research-infrastructures.eu:8080/wsrf/services/gcube/informationsystem/registry/ResourceRegistration
2017-01-13 12:21:13,600 TRACE resources.ISRegistryServiceUpdaterHandler [ServiceThread-60,trace:82] ISRegistryServiceUpdaterHandler: Connecting to the IS-Registry instance located at http://node1.d.d4science.research-infrastructures.eu:8080/wsrf/services/gcube/informationsystem/registry/ResourceRegistration...
2017-01-13 12:21:13,601 DEBUG impl.DefaultScopeProvider [ServiceThread-60,set:38] setting scope /gcube in thread 93
2017-01-13 12:21:13,606 DEBUG impl.DefaultScopeProvider [ServiceThread-60,set:38] setting scope /gcube in thread 93
2017-01-13 12:21:13,667 TRACE resources.UpdateResourceHandler [ServiceThread-60,trace:82] UpdateResourceHandler: Resource with ID=bdaccb35-7f27-45a6-8ca9-11d467cb9233 successfully updated
2017-01-13 12:21:13,668 DEBUG resources.ScopedAnyResource [ServiceThread-60,debug:66] ScopedAnyResource: After the update of bdaccb35-7f27-45a6-8ca9-11d467cb9233
         the ServiceContext is /gcube

The problem is generated in IS-Publisher library but affects only the ResourceManager service.
I'm going to patch the ResourceManager service for avoiding this behavior

#7 Updated by Roberto Cirillo almost 3 years ago

  • Assignee changed from Roberto Cirillo to Lucio Lelii

There is another problem.
In creation phase, the VREModeler service give a list of resources to the ResourceManager service. This list contains all the resources that have to be added to the new VRE.
Unfortunately, this list contains several resources not belonging to the related VO.

e.g. I've tried to create a new VRE in devsec VO and the list of resource that the VREModeler give to the resourceManager contains resources belonging to devNext VO.

This is the ResourceManager report:

<?xml version='1.0' encoding='UTF-8' standalone='yes' ?><ResourceReport><ID>ed7aff70-de5b-11e6-a644-c21f13718aec</ID><Status>CLOSED</Status><SessionExitStatus>SUCCESS</SessionExitStatus><Operation>AddResources</Operation><LastUpdate>2017-01-19T16:28:28+01:00</LastUpdate><TargetScope>/gcube/devsec/TestCreation17</TargetScope><Resources><Resource><ID>34a45250-7b83-11de-aab1-c90492d310da</ID><Type>GenericResource</Type><Status>ADDED</Status></Resource><Resource><ID>bdaccb35-7f27-45a6-8ca9-11d467cb9233</ID><Type>RuntimeResource</Type><Status>ADDED</Status></Resource><Resource><ID>25013220-cf8c-11de-98fe-f6cc6101a7d0</ID><Type>GenericResource</Type><Status>ADDED</Status></Resource><Resource><ID>46474600-7b80-11de-aab1-c90492d310da</ID><Type>GenericResource</Type><Status>ADDED</Status></Resource><Resource><ID>8cbf7080-9aec-11df-a963-ce3cbc9b3b7d</ID><Type>GenericResource</Type><Status>ADDED</Status></Resource><Resource><ID>1cf852f0-25ec-11df-b085-ed2daab1a980</ID><Type>GenericResource</Type><Status>ADDED</Status></Resource><Resource><ID>b5fc38a0-72e0-11de-a424-ad8b9fb939ec</ID><Type>GenericResource</Type><Status>ADDED</Status></Resource><Resource><ID>67d95660-58f6-11df-b6e3-87df51f304f0</ID><Type>GenericResource</Type><Status>ADDED</Status></Resource><Resource><ID>2d62f6a9-5a1c-4329-b315-d4a1da8c4199</ID><Type>RunningInstance</Type><Status>ADDED</Status></Resource><Resource><ID>687af250-ad6b-11e2-bbe7-b131fda1a8f1</ID><Type>RuntimeResource</Type><Status>ADDED</Status></Resource><Resource><ID>d5f63a60-5468-11df-a018-94aa495a68ce</ID><Type>GenericResource</Type><Status>ADDED</Status></Resource><Resource><ID>9498efb0-25ea-11df-b084-ed2daab1a980</ID><Type>GenericResource</Type><Status>ADDED</Status></Resource><Resource><ID>243fdaac-85fb-415c-8af7-bcfa7b5307ad</ID><Type>RuntimeResource</Type><Status>FAILED</Status><ErrorDescription>Can't find resource 243fdaac-85fb-415c-8af7-bcfa7b5307ad on the IS</ErrorDescription></Resource><Resource><ID>1c074460-7862-11de-9c32-c46941cef8c7</ID><Type>GenericResource</Type><Status>ADDED</Status></Resource><Resource><ID>58587a60-25eb-11df-b085-ed2daab1a980</ID><Type>GenericResource</Type><Status>ADDED</Status></Resource><Resource><ID>9ba924ee-3966-4cfe-9d1b-9f07c47832d6</ID><Type>RuntimeResource</Type><Status>FAILED</Status><ErrorDescription>Can't find resource 9ba924ee-3966-4cfe-9d1b-9f07c47832d6 on the IS</ErrorDescription></Resource></Resources><Software /></ResourceReport>

In particular these two resources belonging to /gcube, /gcube/devNext scopes but not to /gcube/devsec scope:

243fdaac-85fb-415c-8af7-bcfa7b5307ad
9ba924ee-3966-4cfe-9d1b-9f07c47832d6

I'm going to assign this ticket to @lucio.lelii@isti.cnr.it for further analysis on VREModeler.

#8 Updated by Lucio Lelii almost 3 years ago

  • Tracker changed from Bug to Task

#9 Updated by Lucio Lelii almost 3 years ago

  • % Done changed from 60 to 100
  • Assignee changed from Lucio Lelii to Roberto Cirillo
  • Status changed from In Progress to Feedback

I have found and solved the issue on the VREModeler service

#10 Updated by Roberto Cirillo almost 3 years ago

  • Status changed from Feedback to Closed

the new VREModeler works very well

Also available in: Atom PDF