Task #6309

D4Science Infrastructure migration to Java 8

Added by Massimiliano Assante almost 3 years ago. Updated about 1 year ago.

Status:ClosedStart date:Jan 09, 2017
Priority:NormalDue date:Feb 24, 2017
Assignee:Gabriele Giammatteo% Done:

100%

Category:-
Sprint:Migrating to Java 8
Infrastructure:Development, Pre-Production, Production
Milestones:
Duration: 35

Description

Now that gCube 4.2 is released, as agreed in the last TCom [1] we should start the migration to Java 8 (starting with the Development infrastructure).

We also agreed that:

  1. Any unexpected behaviours should be communicated by the gCube VRE Social Facility;
  2. ENG should summarise the discussion and best practices in a dedicated Wiki page;
  3. the memory related parameters assigned to the vm have changed (including the behaviour) this deserves in depth investigations;

[1] https://support.d4science.org/projects/bluebridge/wiki/3rd_TCom_Meeting_18-21_October_2016_-_Pisa_(Italy)_#BlueBRIDGE-operation-report

p.s.
I'm going to open separate ticket about the 3 points above and link it to this ticket.


Subtasks

Task #6307: Migrate preproduction infrastructure nodes to Java 8ClosedRoberto Cirillo

Task #6308: Migrate production infrastructure nodes to Java 8Closed_InfraScience Systems Engineer

Task #6306: Migrate development infrastructure nodes to Java 8Closed_InfraScience Systems Engineer

Task #8380: Testing activities on the development infrastructure wit...ClosedMaria Di Girolamo

Task #8424: Dataminer service to test : dataminer1-d-d4s.d4science.org.ClosedGianpaolo Coro

Task #8426: Dataminer service to test : dataminer2-d-d4s.d4science.orgClosedGianpaolo Coro

Task #8427: Quota service to test : quota-d-d4s.d4science.orgClosedAlessandro Pieve

Task #8428: Accounting service to test: accounting-service-d.d4scienc...ClosedAlessandro Pieve

Task #8429: social-networking-ws service to test : socialnetworking-d...ClosedCostantino Perciante

Task #8430: gcube-oauth service to test : socialnetworking-d-d4s.d4sc...ClosedCostantino Perciante

Task #8431: resource-checker-se-plugin service to test : resource-che...ClosedCostantino Perciante

Task #8433: social-data-indexer-se-plugin service to test : node22.d4...ClosedCostantino Perciante

Task #8434: tabular-data-manager service to test : tabulardata-devsec...ClosedLucio Lelii

Task #8435: tabular-data-manager service to update : gcube@node7.d.d4...ClosedRoberto Cirillo

Task #8438: species-product-discovery to test : spd-devsec.d4science.orgClosedLucio Lelii

Task #8439: ckan-connector to test : ckan-d-d4s.d4science.orgClosedLucio Lelii

Task #8440: RConnector to test : rstudio-dev.d4science.orgClosedLucio Lelii

Task #8443: Home Library Webapp to test : node11.d.d4science.resear...ClosedValentina Marioli

Task #8444: sdi-service to test : sdi-d-d4s.d4science.orgClosedFabio Sinibaldi

Task #8445: FHNManager Service to test : node2-d-d4s.d4science.orgClosedNunzio Andrea Galante

Task #8446: DataManager Pool Manager Service to test : node2-d-d4s....ClosedNunzio Andrea Galante

Task #8449: Resource Registry (New IS) to test : resourceregistry1-...ClosedLuca Frosini

Task #8451: Smart Executor to test : smartexecutor1-d-d4s.d4science...ClosedAlessandro Pieve

Task #8452: Smart Executor to test : node6.d4science.orgClosedAlessandro Pieve

Task #8453: Smart Executor to test : node17.d4science.orgClosedLuca Frosini

Task #8454: Smart Executor to test : node19.d4science.orgClosedLuca Frosini

Task #8455: Smart Executor to update : node22.d4science.orgRejected_InfraScience Systems Engineer

Task #8660: tabular-data-manager service to test : tabulardata-devnex...ClosedLucio Lelii

Task #8675: Authorization service to test: auth-d.dev.d4science.orgClosedLucio Lelii

Task #6312: Java 8 unexpected behaviours should be communicated by th...ClosedMaria Di Girolamo

History

#1 Updated by Massimiliano Assante almost 3 years ago

  • Description updated (diff)

#2 Updated by Maria Di Girolamo over 2 years ago

  • Due date changed from Feb 24, 2017 to May 05, 2017

due to changes in a related task

#3 Updated by Maria Di Girolamo over 2 years ago

  • Due date changed from Feb 24, 2017 to May 09, 2017

due to changes in a related task

#4 Updated by Roberto Cirillo over 2 years ago

  • Due date changed from Feb 24, 2017 to May 09, 2017

due to changes in a related task

#5 Updated by Massimiliano Assante over 2 years ago

  • Status changed from New to Planned

#6 Updated by Massimiliano Assante about 1 year ago

  • Status changed from Planned to In Progress

the ticket is old and will be closed. the migration was performed since a while ...

#7 Updated by Massimiliano Assante about 1 year ago

  • Status changed from In Progress to Closed
  • Tracker changed from Upgrade to Task

Also available in: Atom PDF