Task #5584

Please upgrade resource-registry

Added by Luca Frosini about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:Oct 27, 2016
Priority:NormalDue date:
Assignee:_InfraScience Systems Engineer% Done:

100%

Category:Application
Sprint:UnSprintable
Infrastructure:Development
Milestones:
Duration:

Description

The new version is:
resource-registry-1.2.0-20161027.082258-5.war

I already upgraded the version on ansible script ( library/roles/smartgears/resource_registry/defaults/main.yml ) and then I tried to install it.

Unfortunately something is not working properly:
On the target host ( resourceregistry1-d-d4s ) the war is present on home folder but the service which is still deployed is an old version:

cat tomcat/webapps/resource-registry/META-INF/maven/org.gcube.information-system/resource-registry/pom.properties 
#Generated by Apache Maven
#Thu Sep 29 17:13:31 CEST 2016
version=1.1.0-SNAPSHOT
groupId=org.gcube.information-system
artifactId=resource-registry

History

#1 Updated by Luca Frosini about 3 years ago

  • Description updated (diff)

#2 Updated by Luca Frosini about 3 years ago

  • Description updated (diff)

#3 Updated by Andrea Dell'Amico about 3 years ago

  • Status changed from In Progress to Feedback

When upgrading you need to pass an additional variable to the play, so that the old webapp will be removed:

-e 'resource_registry_upgrade=True'

You also need to specify your token, as requested by smartgears 2:

-e 'gcube_admin_token=<TOKEN>'

#4 Updated by Luca Frosini about 3 years ago

  • % Done changed from 30 to 100
  • Status changed from Feedback to Closed

Thanks for yr support

Also available in: Atom PDF