Task #5238

Project WP #641: WP5 - Supporting Blue Assessment: VREs Development [Months: 1-30]

Project Task #642: T5.1 Stock Assessment VRE [Months: 1-30]

Project Activity #1674: VRE Stock Assessment Workplan

WECAFC Stock assessment support

Added by Anton Ellenbroek about 3 years ago. Updated 10 months ago.

Status:ClosedStart date:Nov 18, 2016
Priority:NormalDue date:Jul 31, 2017
Assignee:Anton Ellenbroek% Done:

100%

Category:-
Sprint:WP05
Infrastructure:Production
Milestones:
Duration: 182

Description

Parallel to the FAO stock assessment VRE, this VRE will allow practitioners from the WECAFC region to benefit from services in support of
* Fisheries Management (focussed on tabular data harmonization)
* Stock Assessment (Focussed on DLM tools initially)


Subtasks

Task #5810: SS3 Stock Synthesis V3ClosedEnrico Anello

Task #8500: DLM Toolkit for WECAFC casesClosedAnton Ellenbroek

Task #8501: Validate with CMSY for WECAFC ClosedNathan Vaughan

Task #8502: Apply CMSY to US Caribbean stocks- yellowtail, hogfish, ...ClosedNathan Vaughan

Task #8503: CMSY / DLMtool IntegrationClosedEnrico Anello

Task #8504: Apply CMSY to WECAFC specific stock - Test with one country ClosedNathan Vaughan

Task #8505: Apply CMSY to Flying fishClosedAnton Ellenbroek

Task #9430: Modification of CMSYClosedNathan Vaughan

Task #9869: DLMtoolkit - Shiny interfaceClosedNathan Vaughan


Related issues

Related to BlueBRIDGE - Task #5725: CMSY as-a-Service Closed Dec 18, 2015
Related to BlueBRIDGE - Task #1778: Toolbox for Data Limited Stocks Closed Mar 15, 2017
Related to BlueBRIDGE - Project Activity #4613: FAO Stock Assessment VRE First Release Closed Sep 12, 2017 Oct 31, 2017

History

#1 Updated by Pasquale Pagano about 3 years ago

  • Sprint set to WP04

By when it has to be delivered?

#2 Updated by Anton Ellenbroek about 3 years ago

  • Start date changed from Sep 29, 2016 to Dec 01, 2016
  • Due date set to Feb 01, 2017

FAO and WECAFC are currently investigating on models and data to add and harmonize through TabMan and to analyse with dataminer. After succesfull validation in dataminer, this VRE should allow to combine data and algorithms output in user defined reports. At due date a first skeleton set of models should be operational, and output should be capture in an integrated, reproducible report. An example of a report is given here: https://goo.gl/X9QH50

#3 Updated by Anton Ellenbroek about 3 years ago

The associated VRE will be described here: https://support.d4science.org/projects/bluebridge/wiki/WECAFC_Stock_Assessment

There are several actions in WECAFC that might need separate VRE's;
1. Document elaboration (the currenlty deployed)
2. Stock Assessment (related to CMSY and SS3 activity)
3. Regional Database (related to data collation and harmonization)

We need to discuss how these can be aligned.

#4 Updated by Anton Ellenbroek about 3 years ago

The first model that the community behind this VRE needs to test and validate CMSY:

  1. As a service (as explained in #5725) -> Ready
  2. To generate a PDF or HTML report for dissemination (Nov 2016; RMarkdown examples developed by FAO)
  3. Accessible through a user interface to parametrize the model (Jan 2017)

#5 Updated by Anton Ellenbroek about 3 years ago

#6 Updated by Anton Ellenbroek about 3 years ago

  • Related to Task #1778: Toolbox for Data Limited Stocks added

#7 Updated by Anton Ellenbroek about 3 years ago

#8 Updated by Anton Ellenbroek over 2 years ago

  • Sprint changed from WP04 to WP05

#9 Updated by Anton Ellenbroek over 2 years ago

  • Due date changed from Jul 31, 2017 to May 31, 2017

due to changes in a related task

#10 Updated by Anton Ellenbroek over 2 years ago

  • Due date changed from May 31, 2017 to Jul 31, 2017

due to changes in a related task

#11 Updated by Anton Ellenbroek over 2 years ago

  • VRE_Policy changed from Open to Restricted

#12 Updated by Anton Ellenbroek about 2 years ago

VRE name: WECAFC Toolbox

Description: A VRE managed by WECAFC to support stock assessment processes

  • Upload and harmonize model data; mostly time series of landings, catch and effort;
  • Select a suitable RShiny app built on top of RPackages methods for fisheries (FLR, TropFishR, ...)
  • Parametrize the methods through the UI, and run the analysis
  • Review the results, and if needed, save the results as a PDF or otherwise
  • In some cases, where the methods allows, interactive graphs can be included and the entire experiment can be saved

Details

Some of the methods are relevant to other scenarios as well, and should be re-usable in e.g. the SGD14.4.1 self-learning module.

The selection of models offered through DataMiner is in theory endless. The focus is on DLM methods relevant to the WECAFC region.

Required applications:

  • Data Catalogue
  • TabMan / SDMX to discover suitable existing datasets
  • RStudio
  • SAI
  • RShinyproxy
  • DataMiner, with initially the following algorithms:
    • CMSY
    • CatchMSY
    • WECAFC CMSY
    • YPR

#13 Updated by Massimiliano Assante about 2 years ago

  • Tracker changed from VRE to Task
  • Infrastructure Production added

Because this ticket is child of other ticket it is not cleat the due date of this VRE, this makes really hard to schedule an activity plan. Please provide a due date (somehow) or create a new ticket of type VRE with details about WECAFC Toolbox VRE

#14 Updated by Pasquale Pagano 10 months ago

  • Status changed from New to Closed

Also available in: Atom PDF