Incident #4878

Workspace tree not displaying user's name

Added by Gianpaolo Coro over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:Aug 25, 2016
Priority:NormalDue date:
Assignee:Francesco Mangiacrapa% Done:

100%

Category:Data Management
Infrastructure:Production
Milestones:
Duration:

Description

The WS displays "undefined" instead of the user's name in the right-hand-side tree. Please, see the attachment.

UndefinedWS.png (236 KB) Gianpaolo Coro, Aug 25, 2016 01:20 PM

640

Related issues

Related to gCube - Release #4887: org.gcube.portlets-user.workspace-portlet.6-14-0 Released Aug 29, 2016

History

#1 Updated by Francesco Mangiacrapa over 2 years ago

  • Status changed from New to In Progress

The problem is due to following exception:

SEVERE: Exception while dispatching incoming RPC call
com.google.gwt.user.server.rpc.UnexpectedException: 
Service method 'public abstract org.gcube.portlets.user.workspace.shared.UserBean org.gcube.portlets.user.workspace.client.rpc.GWTWorkspaceService.getMyLogin()' 
threw an unexpected exception: java.lang.NoClassDefFoundError: Could not initialize class com.sun.xml.internal.ws.fault.SOAPFaultBuilder
    at com.google.gwt.user.server.rpc.RPC.encodeResponseForFailure(RPC.java:389)
    at com.google.gwt.user.server.rpc.RPC.invokeAndEncodeResponse(RPC.java:579)
    at com.google.gwt.user.server.rpc.RemoteServiceServlet.processCall(RemoteServiceServ

The UserBean object is not serializable from GWT because it was updated by a new property (the cataloguePermission) which is not serializable, I'm going to fix the issue

#2 Updated by Francesco Mangiacrapa over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

The bug has been fixed and workspace patched version has been deployed in preprod:
https://pre.d4science.org/group/pre/workspace
It will be deployed in production ASAP
I'm going to close this incident.

#3 Updated by Francesco Mangiacrapa over 2 years ago

  • Related to Release #4887: org.gcube.portlets-user.workspace-portlet.6-14-0 added

Also available in: Atom PDF