Task #4379

Update Tomcat7 servers (server.xml) to add cluster configuration

Added by Massimiliano Assante over 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:Jun 23, 2016
Priority:HighDue date:Jul 08, 2016
Assignee:Andrea Dell'Amico% Done:

100%

Category:-
Sprint:D4Science Infrastructure Upgrade to gCube 4.0.0
Infrastructure:Pre-Production, Production
Milestones:
Duration: 12

Description

based on the attached file (host names/ip to replace obviously)

cluster-server.xml Magnifier (1.97 KB) Massimiliano Assante, Jun 23, 2016 12:18 PM


Related issues

Related to D4Science Infrastructure - Upgrade #4328: Preprod Gateway upgrade to gCube 4.0 Completed Jun 22, 2016 Jul 06, 2016

History

#1 Updated by Massimiliano Assante over 3 years ago

  • Related to Upgrade #4328: Preprod Gateway upgrade to gCube 4.0 added

#2 Updated by Massimiliano Assante over 3 years ago

  • Tracker changed from Upgrade to Task

#3 Updated by Massimiliano Assante over 3 years ago

  • Status changed from New to In Progress

#4 Updated by Massimiliano Assante over 3 years ago

  • Status changed from In Progress to Paused

this activity cannot be performed as the HTTP Session cannot be transparently brought on the other instance (due to the fact that we applying the required change on the ASL Session didn't work properly)

#5 Updated by Massimiliano Assante about 3 years ago

  • Parent task deleted (#4327)

#6 Updated by Massimiliano Assante about 3 years ago

  • Assignee changed from Massimiliano Assante to Andrea Dell'Amico
  • Status changed from Paused to In Progress

I did add the tomcat and Liferay cluster configurations on preprod1 and preprod2. However some firewall is blocking the Liferay communication between the 2 nodes (146.48.122.240 and 146.48.122.143)

13:14:19,271 DEBUG [Multicast keep-alive Heartbeat Receiver thread-2][MulticastRMICacheManagerPeerProvider:39] Unable to lookup remote cache peer for //146.48.122.240:60176/com.liferay.portlet.dynamicdatamapping.model.impl.DDMTemplateImpl. Removing from peer list. Cause was: Exception creating connection to: 146.48.122.240; nested exception is: _    java.net.NoRouteToHostException: No route to host [Sanitized]


.orm.FinderCache.com.liferay.sync.model.impl.SyncDLObjectImpl. Removing from peer list. Cause was: Exception creating connection to: 146.48.122.143; nested exception is: _ java.net.NoRouteToHostException: No route to host [Sanitized]
13:14:57,740 DEBUG [Multicast keep-alive Heartbeat Receiver thread-1][MulticastKeepaliveHeartbeatReceiver:48] Aborting processing of rmiUrls since failed to add rmiUrl: //146.48.122.143:59670/com.liferay.portlet.announcements.model.impl.AnnouncementsFlagImpl
13:14:57,740 DEBUG [Multicast keep-alive Heartbeat Receiver thread-3][RMICacheManagerPeerProvider:48] Lookup URL //146.48.122.143:59214/com.liferay.portal.kernel.template.TemplateResourceLoader.ftl
13:14:57,740 DEBUG [Multicast keep-alive Heartbeat Receiver thread-2][MulticastRMICacheManagerPeerProvider:39] Unable to lookup remote cache peer for //146.48.122.143:59670/com.liferay.portlet.dynamicdatamapping.model.impl.DDMTemplateImpl. Removing from peer list. Cause was: Exception creating connection to: 146.48.122.143; nested exception is: _    java.net.NoRouteToHostException: No route to host [Sanitized]
13:14:57,740 DEBUG [Multicast keep-alive Heartbeat Receiver thread-4][MulticastKeepaliveHeartbeatReceiver:48] Aborting processing of rmiUrls since failed to add rmiUrl: //146.48.122.143:59214/com.liferay.portal.kernel.dao.orm.FinderCache.com.liferay.sync.model.impl.SyncDLObjectImpl
13:14:57,740 DEBUG [Multicast keep-alive Heartbeat Receiver thread-2][MulticastKeepaliveHeartbeatReceiver:48] Aborting processing of rmiUrls since failed to add rmiUrl: //146.48.122.143:59670/com.liferay.portlet.dynamicdatamapping.model.impl.DDMTemplateImpl
13:14:57,740 DEBUG [Multicast keep-alive Heartbeat Receiver thread-3][MulticastRMICacheManagerPeerProvider:39] Unable to lookup remote cache peer for //146.48.122.143:59214/com.liferay.portal.kernel.template.TemplateResourceLoader.ftl. Removing from peer list. Cause was: Exception creating connection to: 146.48.122.143; nested exception is: _    java.net.NoRouteToHostException: No route to host [Sanitized]
13:14:57,741 DEBUG [Multicast keep-alive Heartbeat Receiver thread-3][MulticastKeepaliveHeartbeatReceiver:48] Aborting processing of rmiUrls since failed to add rmiUrl: //146.48.122.143:59214/com.liferay.portal.kernel.template.TemplateResourceLoader.ftl

#7 Updated by Massimiliano Assante about 3 years ago

  • Priority changed from Normal to High

#8 Updated by Andrea Dell'Amico about 3 years ago

  • % Done changed from 0 to 90
  • Infrastructure Pre-Production added

The nodes need to communicate via RMI too. Now that traffic is permitted. I changed the firewall rules both on preproduction and production.

#9 Updated by Massimiliano Assante about 3 years ago

  • % Done changed from 90 to 100
  • Status changed from In Progress to Closed

thanks, now the 2 preprod nodes can communicate correctly.

Also available in: Atom PDF