Release #3637

Release #2224: gCube Release 3.11.0-gcore

Release #3624: org.gcube.data-analysis.3-11-0-gcore

org.gcube.data-analysis.statistical-manager-gcubews.2.0.0-1(gCore)

Added by Maria Di Girolamo over 3 years ago. Updated over 3 years ago.

Status:ReleasedStart date:Apr 18, 2016
Priority:HighDue date:
Assignee:Fabio Sinibaldi
Category:data-analysis
Sprint:gCube Release 3.11.0 - gCore
Wiki Updates: Version Control System:
Type: Building System:
Milestones:
Duration:

Related issues

Copied from gCube - Release #3636: org.gcube.data-analysis.statistical-manager-gcubews.2.0.0-1 Removed Apr 18, 2016
Copied to gCube - Release #4022: org.gcube.data-analysis.statistical-manager-gcubews.2.0.0... Released Apr 18, 2016

History

#1 Updated by Maria Di Girolamo over 3 years ago

  • Copied from Release #3636: org.gcube.data-analysis.statistical-manager-gcubews.2.0.0-1 added

#2 Updated by Maria Di Girolamo over 3 years ago

  • Status changed from Removed to Under Integration

#3 Updated by Maria Di Girolamo over 3 years ago

Please. could you remove the following components from the configuration:
1)org.gcube.data-analysis.ecological-engine-smart-executor

2)org.gcube.data-analysis.ecological-engine-wps-extension

3)org.gcube.data-analysis.ecological-engine-geospatial-extensions

These components are the smart-gear components (directly/indirectly) .

#4 Updated by Maria Di Girolamo over 3 years ago

  • Status changed from Under Integration to Build Issue

#5 Updated by Fabio Sinibaldi over 3 years ago

Hi,
these are needed dependencies. In my understanding common libraries need to by built in gCore release too in order to continue to maintain gCore services. Am I wrong here?

#6 Updated by Gabriele Giammatteo over 3 years ago

if we keep statistical-manager as it is, we need to add to gCube 3.11.0-gcore also smart-executor-client and smart-executor-api. It is not an issue per-se, but they, in turn, depend on smart-executor-hello-world-plugin, which depends on smartgears-bom.

statistical-manager --> ecological-engine-smart-executor --> smart-exectuor-client --> hello-world-plugin --> smartgears-bom

Since we cannot have smartgears-bom in gCube 3.11.0-gcore, we have to break the chain at some point.

The only other possibility I see as feasible could be to remove hello-world-plugin dependency from smart-executor-(client, api). @luca.frosini@isti.cnr.it does this make sense/is it possible?

@gianpaolo.coro@isti.cnr.it another possibility would be to remove the dependency ecological-engine-smart-executor --> smart-exectuor-client. But, looking at the naming of the components I guess it's impossible, right?

#7 Updated by Maria Di Girolamo over 3 years ago

  • Priority changed from Normal to High

Please , could you resolve this issue ?
Tomorrow we will close the org.gcube.3.11.0 and org.gcube.3.11.0-release.

#8 Updated by Gianpaolo Coro over 3 years ago

I cannot delete the dependency, but I do believe that hello-world-plugin should be removed from the release.

#9 Updated by Luca Frosini over 3 years ago

I have the dependency to helloworld plugin for testing purpose only, so that ETICS requires that dependency.
I can remove the tests from branch and clone the configuration to update the revision number.

#10 Updated by Gabriele Giammatteo over 3 years ago

Yes please. The other option would be to mock the behaviour of a smart-executor-plugin in you unit tests

#11 Updated by Luca Frosini over 3 years ago

I removed them because they are already removed from trunk for next release.
Done. I also created the tickets #4019 #4020 and changed the subsystem configuration on etics

#12 Updated by Maria Di Girolamo over 3 years ago

  • Copied to Release #4022: org.gcube.data-analysis.statistical-manager-gcubews.2.0.0-2(gCore) added

#13 Updated by Fabio Sinibaldi over 3 years ago

is this issue still in place?

#14 Updated by Maria Di Girolamo over 3 years ago

  • Status changed from Build Issue to Under Integration

#15 Updated by Maria Di Girolamo over 3 years ago

  • Status changed from Under Integration to Released

Also available in: Atom PDF