Feature #2354

Make smartgears zero dependencies

Added by Luca Frosini almost 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:Feb 25, 2016
Priority:NormalDue date:Mar 31, 2016
Assignee:Luca Frosini% Done:

100%

Category:common
Sprint:zz - Smartgears Improvements & Fixes
Milestones:
Duration: 26

Description

Tomcat 7.0.68 contains the following libraries:

  • annotations-api.jar
  • catalina-ant.jar
  • catalina-ha.jar
  • catalina.jar
  • catalina-tribes.jar
  • ecj-4.4.2.jar
  • el-api.jar
  • jasper-el.jar
  • jasper.jar
  • jsp-api.jar
  • servlet-api.jar
  • tomcat7-websocket.jar
  • tomcat-api.jar
  • tomcat-coyote.jar
  • tomcat-dbcp.jar
  • tomcat-i18n-es.jar
  • tomcat-i18n-fr.jar
  • tomcat-i18n-ja.jar
  • tomcat-jdbc.jar
  • tomcat-util.jar
  • websocket-api.jar

Subtasks

Feature #2355: Remove dependency commons-io from common-smartgearsClosedLucio Lelii

Feature #2356: Remove jackson-mapper-asl from couchdb-connectorClosedLuca Frosini

Feature #2357: Remove reflections dependency from document-store-libClosedLuca Frosini

Feature #2358: Remove reflections dependency from accounting-libClosedLuca Frosini

Feature #2359: Remove reflections dependency from common-authorization 2...ClosedLucio Lelii

History

#1 Updated by Luca Frosini almost 4 years ago

  • Description updated (diff)

#2 Updated by Luca Frosini almost 4 years ago

Smartgears Distribution add the following libraries (in striked bold the external dependencies to be removed, and in italic bold the external dependencies must be keep);

accounting-lib-2.1.0-20160216.153753-3.jar
annotations-2.0.1.jar
authorization-client-1.0.0-20151124.224825-69.jar
common-authorization-1.0.0-20151124.224059-88.jar
common-clients-2.1.0-20160126.091445-999.jar
common-configuration-scanner-1.1.0-20160216.142528-31.jar
common-encryption-1.0.2-20160125.232809-260.jar
common-events-1.0.1-20160216.143021-549.jar
common-gcore-resources-1.3.1-20160216.143251-215.jar
common-gcore-stubs-1.2.0-20150928.160449-523.jar
common-generic-clients-1.0.0-20151221.223520-580.jar
common-scope-1.2.1-20160125.232521-534.jar
common-scope-maps-1.0.2-20160128.102417-1003.jar
commons-io-2.4.jar
common-smartgears-1.2.5-20160118.110930-1.jar
common-smartgears-utils-1.0.1-20151222.115036-81.jar
common-validator-1.0.0-20160215.233251-823.jar
couchdb-connector-1.1.0-20160216.141034-85.jar
discovery-client-1.0.1-20160216.144012-1639.jar
document-store-lib-1.0.1-20160216.153706-10.jar
document-store-lib-couchdb-1.0.1-20160216.153716-2.jar
guava-15.0.jar
ic-client-1.0.2-20151221.223143-338.jar
jackson-core-asl-1.9.13.jar
jackson-mapper-asl-1.9.13.jar
javassist-3.19.0-GA.jar
logback-classic-1.0.13.jar
logback-core-1.0.13.jar
reflections-0.9.10.jar
registry-publisher-1.2.5-20151221.223209-383.jar
slf4j-api-1.7.5.jar

#3 Updated by Luca Frosini almost 4 years ago

reflections-0.9.10.jar is used from document-store-lib and accounting-lib and is the cause of adding guava-15.0.jar, annotations-2.0.1.jar and javassist-3.19.0-GA.jar
@luca.frosini@isti.cnr.it and @lucio.lelii@isti.cnr.it will investigate a workaround to remove it (see #2357, #2358 #2359)

jackson-core-asl-1.9.13.jar and jackson-mapper-asl-1.9.13.jar are used from couchdb-connector. @lucio.lelii@isti.cnr.it will investigate how to remove this (see #2356).

commons-io-2.4.jar si used from common-smartgears. @lucio.lelii@isti.cnr.it will investigate how to remove this (see #2355).

#4 Updated by Luca Frosini almost 4 years ago

We cannot avoid the use of slf4j-api-1.7.5.jar, logback-classic-1.0.13.jar, logback-core-1.0.13.jar, because even we repackage them they are dynamically discovered and the conflict is only a runtime behaviour.

#5 Updated by Luca Frosini almost 4 years ago

  • Status changed from New to In Progress

#6 Updated by Luca Frosini almost 4 years ago

The actual situation is the following (in striked bold the external dependencies to be removed, and in italic bold the external dependencies must be keep);

accounting-lib-2.2.0-SNAPSHOT.jar
authorization-client-1.0.0-20151124.224825-69.jar
common-authorization-1.0.0-20151124.224059-88.jar
common-clients-2.1.0-20160126.091445-999.jar
common-configuration-scanner-1.1.0-20160229.234449-49.jar
common-encryption-1.0.2-20160125.232809-260.jar
common-events-1.0.1-20160301.005809-567.jar
common-gcore-resources-1.3.2-20160229.234356-15.jar
common-gcore-stubs-1.2.0-20150928.160449-523.jar
common-generic-clients-1.0.0-20151221.223520-580.jar
common-scope-1.2.1-20160125.232521-534.jar
common-scope-maps-1.0.2-20160128.102417-1003.jar
common-smartgears-1.2.7-SNAPSHOT.jar
common-validator-1.0.0-20160229.235022-842.jar
couchdb-connector-1.1.0-20160301.010600-100.jar
discovery-client-1.0.1-20160221.233135-1646.jar
document-store-lib-1.1.0-SNAPSHOT.jar
document-store-lib-couchdb-1.0.1-SNAPSHOT.jar
ic-client-1.0.2-20151221.223143-338.jar
jackson-core-asl-1.9.13.jar
jackson-mapper-asl-1.9.13.jar
logback-classic-1.0.13.jar
logback-core-1.0.13.jar
registry-publisher-1.2.6-20160217.155033-1.jar
slf4j-api-1.7.5.jar

jackson-core-asl-1.9.13.jar and jackson-mapper-asl-1.9.13.jar are used from couchdb-connector. They will be removed when the ticket #2356 will be closed by @lucio.lelii@isti.cnr.it .

#7 Updated by Luca Frosini almost 4 years ago

  • Status changed from In Progress to Closed

#8 Updated by Luca Frosini almost 4 years ago

#9 Updated by Andrea Dell'Amico almost 4 years ago

  • Related to Bug #2472: tomcat cannot parse the javaassist annotation classes added

#10 Updated by Luca Frosini almost 4 years ago

  • Related to deleted (Bug #2472: tomcat cannot parse the javaassist annotation classes)

#11 Updated by Luca Frosini over 3 years ago

Also available in: Atom PDF