Support #2003

Java 8 support in the infrastructure

Added by Gerasimos Farantatos almost 3 years ago. Updated over 2 years ago.

Status:ClosedStart date:Jan 18, 2016
Priority:NormalDue date:
Assignee:Gabriele Giammatteo% Done:

0%

Category:-
Sprint:WP04
Infrastructure:
Milestones:
Duration:

Description

There is a requirement, especially for the software developed under WP6 but also for other WPs in which UoA is involved to have Java 8 runtime support in the infrastructure.

Especially for WP6 there is existing code which is to be ported to gCube requiring Java 8 features and new components are of course expected also to require this version.

I would therefore like to ask if the infrastructure currently supports Java 8. If not, can a solution be found so that at least new software can run on that runtime?

History

#1 Updated by Pasquale Pagano almost 3 years ago

Java 8 support is planned but not yet released. Waiting for @gabriele.giammatteo@eng.it information, I think that we can start support its runtime (updating all the nodes) on the infrastructure while continuing building with Java 7. What @gabriele.giammatteo@eng.it and @roberto.cirillo@isti.cnr.it think?

#2 Updated by Gabriele Giammatteo almost 3 years ago

I can confirm that the upgrade should start from runtimes (of gCube nodes and development environments) and then start to build packages with Java 8. The other way round won't work because we will have packages that our runtimes cannot execute. If the need of WP6 is to test and/or deploy software very soon, as a temporary solution, update only the node(s) that host the application and compile the application locally (or with special set-up of its ETICS configuration) could work

#3 Updated by Gabriele Giammatteo over 2 years ago

  • Status changed from New to Closed

I'm closing the request: there will be support for Java 8, although the upgrade is not yet scheduled. We will open specific tickets for this as soon as we schedule the activity.

Also available in: Atom PDF