SW Test #16571

SW Test #16559: gCube Release 4.14.0 - FT Testing

SW Test #16561: org.gcube.portlets-user.4-14-0

org.gcube.portlets-user.shareupdates.2-7-0

Added by Luca Frosini 9 months ago. Updated 20 days ago.

Status:ClosedStart date:Apr 17, 2019
Priority:NormalDue date:
Assignee:Fabio Sinibaldi% Done:

100%

Category:portlets-user
Sprint:gCube Release 4.14.0 - FT Testing
Milestones:
Duration:

Description

@massimiliano.assante@isti.cnr.it can you update the testing plan?

ShareUpdates- test report.xlsx (14.4 KB) Fabio Sinibaldi, Apr 30, 2019 05:39 PM


Related issues

Related to gCube - Task #13207: Revise social networking library mechanism for http links... Closed Jan 22, 2019

History

#2 Updated by Luca Frosini 9 months ago

  • Assignee changed from Luca Frosini to Lucio Lelii

#3 Updated by Luca Frosini 9 months ago

  • Assignee changed from Lucio Lelii to Fabio Sinibaldi

#4 Updated by Luca Frosini 9 months ago

The portlet is available in preprod. @fabio.sinibaldi@isti.cnr.it please start the tests as soon as possible.

#5 Updated by Fabio Sinibaldi 9 months ago

  • Status changed from Available to Under Testing

#6 Updated by Fabio Sinibaldi 9 months ago

  • Status changed from Under Testing to Test Issue

Test step #13 doesn't work. Trying to post multiple times did not produce any effect. @massimiliano.assante@isti.cnr.it

#7 Updated by Massimiliano Assante 9 months ago

  • Assignee changed from Fabio Sinibaldi to Massimiliano Assante

Thank you @fabio.sinibaldi@isti.cnr.it, I can reproduce the issue you found.

@luca.frosini@isti.cnr.it there is an java.lang.StringIndexOutOfBoundsException in the new parser you developed when this text is used, can you help?

Dear members,
The item 'Webinar on Ontology Management using VOCBENCH in the context of AGINFRAPLUS Project' has been just published by Leonardo Candela .
You can find it here: http://data.d4science.org/ctlg/AGINFRAplus/webinar_on_ontology_management_using_vocbench_in_the_context_of_aginfraplus_project 
#AGINFRAPLUS #VOCBENCH

stack trace:

SEVERE: Exception while dispatching incoming RPC call
com.google.gwt.user.server.rpc.UnexpectedException: Service method 'public abstract org.gcube.portal.databook.shared.ClientFeed org.gcube.portlets.user.shareupdates.client.ShareUpdateService.sharePostWithLinkPreview(java.lang.String,org.gcube.portal.databook.shared.FeedType,org.gcube.portal.databook.shared.PrivacyLevel,java.lang.Long,org.gcube.portlets.user.shareupdates.shared.LinkPreview,java.lang.String,java.util.ArrayList,boolean)' threw an unexpected exception: java.lang.StringIndexOutOfBoundsException: String index out of range: -1
... 
Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: -1
    at java.lang.String.substring(String.java:1927)
    at org.gcube.socialnetworking.socialtoken.SanitizedURL.<init>(SanitizedURL.java:32)
    at org.gcube.socialnetworking.socialtoken.URLToken.isURL(URLToken.java:46)
    at org.gcube.socialnetworking.socialtoken.SocialMessageParser.getTokens(SocialMessageParser.java:47)
    at org.gcube.socialnetworking.socialtoken.SocialMessageParser.getParsedMessage(SocialMessageParser.java:78)
    at org.gcube.socialnetworking.socialtoken.SocialMessageParser.getParsedMessage(SocialMessageParser.java:88)
    at org.gcube.portlets.user.shareupdates.server.ShareUpdateServiceImpl.sharePostWithLinkPreview(ShareUpdateServiceImpl.java:154)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at com.google.gwt.user.server.rpc.RPC.invokeAndEncodeResponse(RPC.java:561)
    ... 41 more

#8 Updated by Massimiliano Assante 9 months ago

  • Related to Task #13207: Revise social networking library mechanism for http links, mentions and hashtags recognition added

#9 Updated by Luca Frosini 9 months ago

I'm investigating the issue

#10 Updated by Luca Frosini 9 months ago

I have fixed the issue and updated the ETICS configuration of org.gcube.social-networking.social-util-library.1-6-0.
The remote build is running.
@massimiliano.assante@isti.cnr.it once terminated, can you update the portlet again?

#11 Updated by Luca Frosini 9 months ago

@massimiliano.assante@isti.cnr.it ETICS build succeeded

#12 Updated by Massimiliano Assante 9 months ago

  • Assignee changed from Massimiliano Assante to Fabio Sinibaldi
  • Status changed from Test Issue to Available

The fix has been done and verified, however the testing plan must be (unfortunately) repeated from the beginning as the fix may have broken sth else.

#13 Updated by Fabio Sinibaldi 9 months ago

  • Status changed from Available to Under Testing

#14 Updated by Fabio Sinibaldi 9 months ago

Test plan successfully performed.
Report in attachment.

#15 Updated by Fabio Sinibaldi 20 days ago

  • Status changed from Tested on Preprod to Closed

Also available in: Atom PDF