VM Creation #13149

gCube - Task #13068: PerformFISH Analytical Toolkit Service

perform-service production instance

Added by Fabio Sinibaldi about 1 month ago. Updated about 1 month ago.

Status:ClosedStart date:Jan 08, 2019
Priority:NormalDue date:
Assignee:_InfraScience Systems Engineer% Done:

100%

Sprint:PerformFish
Infrastructure:Production Applications list and version:

RAM:4 Applications context path:

perform-service

CPU:2 External storage data disk:

DiskSpace:10 Smartgears auth connector:
Smartgears:Yes data transfer enabled:No
Smartgears Version:LATEST PostgreSQL database:No
Application Instructions:

Number of VMs:1
Smartgears scopes:

/d4science.research-infrastructures.eu/FARM/PerformFISH-KPIs

Milestones:
Duration:

Description

A new VM is needed in order to test the new service 'perform-service'.

Such service needs to connect to the VRE's perform-fish-db as manager (see ticket #13111 for database details).


Related issues

Copied from D4Science Infrastructure - VM Creation #13112: perform-service development instance Closed Jan 08, 2019

History

#1 Updated by Fabio Sinibaldi about 1 month ago

#2 Updated by Andrea Dell'Amico about 1 month ago

Is there a production DB or is it meant to connect to the dev one?

#3 Updated by Fabio Sinibaldi about 1 month ago

The production DB published as Service Endpoint

Category = Database
Name = PF_DB

is currently pf_kpi_apps hosted on postgresql-srv.d4science.org:5432

Please take #13111 into account for database configuration.

#4 Updated by Tommaso Piccioli about 1 month ago

  • % Done changed from 0 to 40
  • Status changed from New to In Progress

new VM perform.d4science.org ready to be provided

#5 Updated by Andrea Dell'Amico about 1 month ago

  • % Done changed from 40 to 90

There's a problem with the container. The error below is from the production instance, but I expect an identical one on preproduction:

2019-01-15 17:36:11,941 [localhost-startStop-1] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/perform-service]- Exception sending context initialized event to listener instance of class org.gcube.smartgears.ContextListener
java.lang.RuntimeException: /perform-service is a gCube-aware application but is not managed as a gCube resource: missing or invalid context attribute gcube-application-context
        at org.gcube.smartgears.ContextListener.contextInitialized(ContextListener.java:35)
        at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:5019)
        at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5513)
        at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:632)
        at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:1073)
        at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1857)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
        at java.lang.Thread.run(Thread.java:748)
2019-01-15 17:36:11,943 [localhost-startStop-1] ERROR org.apache.catalina.core.StandardContext- Error listenerStart
2019-01-15 17:36:11,944 [localhost-startStop-1] ERROR org.apache.catalina.core.StandardContext- Context [/perform-service] startup failed due to previous errors

#6 Updated by Andrea Dell'Amico about 1 month ago

I see that there's no gcube-app.xml file inside WEB-INF.

#7 Updated by Fabio Sinibaldi about 1 month ago

Thanks for the hint, it's probably the right cause. I'm gonna fix it now.

#8 Updated by Andrea Dell'Amico about 1 month ago

  • % Done changed from 90 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF