Bug #12525

GXInboundResponse returns a NullPointerException when AcceptedResponseType is not set

Added by Lucio Lelii over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:Sep 20, 2018
Priority:NormalDue date:
Assignee:Manuele Simi% Done:

100%

Category:common
Sprint:zz - GXRest
Milestones:
Duration:

History

#1 Updated by Manuele Simi over 1 year ago

Can you please add the stack trace? It would help the investigation.

#2 Updated by Lucio Lelii over 1 year ago

java.lang.RuntimeException: java.lang.NullPointerException
at org.gcube.common.storagehub.client.proxies.DefaultWorkspaceManager.getWorkspace(DefaultWorkspaceManager.java:59)
at org.gcube.data.access.fs.TestCall.getListByPath(TestCall.java:62)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:45)
at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:42)
at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:263)
at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:68)
at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:47)
at org.junit.runners.ParentRunner$3.run(ParentRunner.java:231)
at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:60)
at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:229)
at org.junit.runners.ParentRunner.access$000(ParentRunner.java:50)
at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:222)
at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:28)
at org.junit.runners.ParentRunner.run(ParentRunner.java:300)
at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:86)
at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:538)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:760)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:460)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:206)
Caused by: java.lang.NullPointerException
at org.gcube.common.gxrest.response.inbound.GXInboundResponse.(GXInboundResponse.java:121)
at org.gcube.common.gxrest.request.GXWebTargetAdapterRequest.buildGXResponse(GXWebTargetAdapterRequest.java:205)
at org.gcube.common.gxrest.request.GXWebTargetAdapterRequest.get(GXWebTargetAdapterRequest.java:164)
at org.gcube.common.storagehub.client.proxies.DefaultWorkspaceManager$1.call(DefaultWorkspaceManager.java:47)
at org.gcube.common.storagehub.client.proxies.DefaultWorkspaceManager$1.call(DefaultWorkspaceManager.java:1)
at org.gcube.common.clients.delegates.DiscoveryDelegate.make(DiscoveryDelegate.java:145)
at org.gcube.common.storagehub.client.proxies.DefaultWorkspaceManager.getWorkspace(DefaultWorkspaceManager.java:56)
... 25 more

#3 Updated by Lucio Lelii over 1 year ago

  • Subject changed from GXInboundResponse return a NullPointerException when AcceptedResponseType is not set to GXInboundResponse returns a NullPointerException when AcceptedResponseType is not set

#4 Updated by Manuele Simi over 1 year ago

  • Status changed from New to In Progress

#5 Updated by Manuele Simi over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Resolved

This is fixed. @lucio.lelii@isti.cnr.it please, test the deployed snapshot and close the ticket if confirmed.

#6 Updated by Manuele Simi over 1 year ago

  • Status changed from Resolved to Closed

Please, open again the issue if the error occurs again.

Also available in: Atom PDF