Support #11810

VRE #10195: FAO Training VRE on Stock monitoring tools

Deploy new version of the StockMonitoringTools Shiny App

Added by Enrico Anello over 1 year ago. Updated 2 months ago.

Status:ClosedStart date:May 21, 2018
Priority:UrgentDue date:
Assignee:_InfraScience Systems Engineer% Done:

100%

Category:Default
Sprint:Algorithms Integration
Infrastructure:Production
Milestones:
Duration:

Description

Dear all,
We need to deploy the latest, and possible the final, release of the Stock Monitoring Tools to be made available within the SDG-Indicator 14.4.1 VRE.
The Source code of the shiny application can be found on github here: https://github.com/pink-sh/StockMonitoringTool (master branch). On the repository root you can find the Dockerfile needed to build the application for your shinyproxy.

Thanks,
Enrico

History

#1 Updated by Enrico Anello about 1 year ago

  • Priority changed from High to Urgent

Hi, any news about this?

#2 Updated by Massimiliano Assante about 1 year ago

Hi Enrico, Andrea is on holiday, will return next week.

#3 Updated by Andrea Dell'Amico about 1 year ago

  • Assignee changed from Andrea Dell'Amico to _InfraScience Systems Engineer

Massimiliano Assante wrote:

Hi Enrico, Andrea is on holiday, will return next week.

If only it were true :-). I'm back, I'll do the build ASAP.

#4 Updated by Andrea Dell'Amico about 1 year ago

  • Status changed from New to In Progress

#5 Updated by Andrea Dell'Amico about 1 year ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Feedback

I just pulled the new container image on the shinyproxy server. Can you check that it's working?

#6 Updated by Enrico Anello about 1 year ago

Hi @andrea.dellamico@isti.cnr.it
The shiny app works even if the CMSY method seems quite unstable; it fails 4 times on 5.
Since the CMSY method relies on the Dataminer algorithm I am not sure if the problem is on the Dataminer or somewhere else even though in my local machine everything works fine. Do you perhaps have access to the logs of the shiny app? There might be some timeout issue.

Also, how many concurrent connections the shiny app does currently support?

Thank you,
Enrico

#7 Updated by Andrea Dell'Amico about 1 year ago

Enrico Anello wrote:

Hi @andrea.dellamico@isti.cnr.it
The shiny app works even if the CMSY method seems quite unstable; it fails 4 times on 5.
Since the CMSY method relies on the Dataminer algorithm I am not sure if the problem is on the Dataminer or somewhere else even though in my local machine everything works fine. Do you perhaps have access to the logs of the shiny app? There might be some timeout issue.

There are errors on the shinyproxy app but they seem not to be related to the algorithm failure:

2018-05-30 11:04:16.057 ERROR 885 --- [XNIO-2 I/O-8] io.undertow.proxy                        : UT005028: Proxy request to /stoic_bohr/shared/ionrangeslider/css/ion.rangeSlider.skinShiny.css failed

java.io.IOException: UT001000: Connection closed
        at io.undertow.client.http.HttpClientConnection$ClientReadListener.handleEvent(HttpClientConnection.java:544) ~[undertow-core-1.4.11.Final.jar!/:1.4.11.Final]
        at io.undertow.client.http.HttpClientConnection$ClientReadListener.handleEvent(HttpClientConnection.java:487) ~[undertow-core-1.4.11.Final.jar!/:1.4.11.Final]
        at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:92) ~[xnio-api-3.3.6.Final.jar!/:3.3.6.Final]
        at org.xnio.conduits.ReadReadyHandler$ChannelListenerHandler.readReady(ReadReadyHandler.java:66) [xnio-api-3.3.6.Final.jar!/:3.3.6.Final]
        at org.xnio.nio.NioSocketConduit.handleReady(NioSocketConduit.java:88) [xnio-nio-3.3.6.Final.jar!/:3.3.6.Final]
        at org.xnio.nio.WorkerThread.run(WorkerThread.java:559) [xnio-nio-3.3.6.Final.jar!/:3.3.6.Final]

I tried a couple of runs and they completed, if you manage to get another failure can you tell us immediately so that we can check the container logs? when a container is stopped, we lose its logs.

Also, how many concurrent connections the shiny app does currently support?

The shinyproxy server has 12 vCPUs, so 12 concurrent instances are allowed.

Thank you,
Enrico

#8 Updated by Enrico Anello about 1 year ago

Now seems working fine.
I will share the application with the users for a preliminary check and we will see how it goes.
Thanks @andrea.dellamico@isti.cnr.it

Enrico

#9 Updated by Pasquale Pagano about 1 year ago

  • Status changed from Feedback to Closed

#10 Updated by Enrico Anello 3 months ago

  • Status changed from Closed to In Progress

Hi everybody,
A new version of the stock monitoring tools needs to be deployed on the SDG 14.4.1 VRE.
The source code with the Dockerfile can be found here: https://github.com/pink-sh/StockMonitoringTool

#11 Updated by Andrea Dell'Amico 3 months ago

The build is running.

Next time open a new ticket, please.

#12 Updated by Andrea Dell'Amico 3 months ago

@enrico.anello@fao.org the build fails:

Step 13/18 : RUN R -e "devtools::install_version('TropFishR', version='1.2', repos = 'http://cran.us.r-project.org')"
 ---> Running in 410d38b5af60

R version 3.4.4 (2018-03-15) -- "Someone to Lean On"
Copyright (C) 2018 The R Foundation for Statistical Computing
Platform: x86_64-pc-linux-gnu (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

  Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

> devtools::install_version('TropFishR', version='1.2', repos = 'http://cran.us.r-project.org')
Downloading package from url: http://cran.us.r-project.org/src/contrib/Archive/TropFishR/TropFishR_1.2.tar.gz
bit          (NA    -> 1.1-14     ) [CRAN]
doParallel   (NA    -> 1.0.14     ) [CRAN]
expm         (NA    -> 0.999-4    ) [CRAN]
ff           (NA    -> 2.2-14     ) [CRAN]
foreach      (NA    -> 1.4.4      ) [CRAN]
GA           (NA    -> 3.2        ) [CRAN]
GenSA        (NA    -> 1.1.7      ) [CRAN]
gmm          (NA    -> 1.6-2      ) [CRAN]
iterators    (NA    -> 1.0.10     ) [CRAN]
minpack.lm   (NA    -> 1.2-1      ) [CRAN]
msm          (NA    -> 1.6.7      ) [CRAN]
propagate    (NA    -> 1.0-6      ) [CRAN]
RcppArmad... (NA    -> 0.9.400.2.0) [CRAN]
sandwich     (NA    -> 2.5-1      ) [CRAN]
stringi      (1.1.7 -> 1.4.3      ) [CRAN]
stringr      (1.3.0 -> 1.4.0      ) [CRAN]
tmvtnorm     (NA    -> 1.4-10     ) [CRAN]
zoo          (NA    -> 1.8-5      ) [CRAN]
Skipping 1 packages not available: mvtnorm
Installing 19 packages: bit, doParallel, expm, ff, foreach, GA, GenSA, gmm, iterators, minpack.lm, msm, mvtnorm, propagate, RcppArmadillo, sandwich, stringi, stringr, tmvtnorm, zoo
Installing packages into ‘/usr/local/lib/R/site-library’
(as ‘lib’ is unspecified)
Error: (converted from warning) package ‘mvtnorm’ is not available (for R version 3.4.4)
In addition: Warning message:
In is.na(remote_deps$package) :
  is.na() applied to non-(list or vector) of type 'NULL'
Execution halted
The command '/bin/sh -c R -e "devtools::install_version('TropFishR', version='1.2', repos = 'http://cran.us.r-project.org')"' returned a non-zero code: 1

#13 Updated by Enrico Anello 3 months ago

@andrea.dellamico@isti.cnr.it

I just tested the Docker image on my local machine and builds without any problem.
What I did though is to get rid of any old version of either stock-monitoring-tools and openanalytics/r-base docker images before building. Forcing the build to download all the latest versions.

In fact from your build and mine I see two different R versions. Yours states R version 3.4.4, my build eventually runs with R version 3.5.3
This can indeed cause the issue you reported and might be because your build is using an old image of openalytics/r-base

Let me know if this helps.

Enrico

#14 Updated by Andrea Dell'Amico 3 months ago

It's possible, I run with --no-cache but I didn't remove the old images. I'm retrying.

#15 Updated by Andrea Dell'Amico 3 months ago

  • Status changed from In Progress to Feedback

The new version should be online.

For the future: why don't you publish it into docker hub and activate the automate build there? it would speed up the deployment.

#16 Updated by Enrico Anello 3 months ago

  • Status changed from Feedback to Closed

#17 Updated by Enrico Anello 3 months ago

  • Status changed from Closed to In Progress

Dear @andrea.dellamico@isti.cnr.it
I tried to create a new ticket but somehow it doesnt work. So I reopen this one.

The deploy worked last week but some further minor changes were needed to the tool. Can you please re-deploy the version?

Thanks,
Enrico

#18 Updated by Pasquale Pagano 3 months ago

@enrico.anello@fao.org, the project BlueBRIDGE has ended on February 2018. For this reason it is not possible to open a new ticket on this project.

Next time, please open a support request on the D4Science Support project.

#19 Updated by Andrea Dell'Amico 3 months ago

Enrico Anello wrote:

I tried to create a new ticket but somehow it doesnt work. So I reopen this one.

The deploy worked last week but some further minor changes were needed to the tool. Can you please re-deploy the version?

Did you push your changes?

docker_build@docker-build1:~/builds/StockMonitoringTool$ git pull
Current branch master is up to date.

#20 Updated by Enrico Anello 3 months ago

Sorry @andrea.dellamico@isti.cnr.it , forgot to push :)
Try again

#21 Updated by Andrea Dell'Amico 3 months ago

  • Status changed from In Progress to Feedback

The application has been updated.

#22 Updated by Andrea Dell'Amico 2 months ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF