Task #11369

VMs with docker do not start the firewall correctly at boot time

Added by Roberto Cirillo over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:Mar 06, 2018
Priority:NormalDue date:
Assignee:_InfraScience Systems Engineer% Done:

100%

Category:System Application
Sprint:UnSprintable
Infrastructure:Production
Milestones:
Duration:

Related issues

Related to BlueBRIDGE - Support #11361: Sharelatex Error Closed Mar 06, 2018

History

#1 Updated by Roberto Cirillo over 1 year ago

#2 Updated by Pasquale Pagano over 1 year ago

any news?

#3 Updated by Andrea Dell'Amico over 1 year ago

The existing VMs were fixed as soon as the problem arised. I just started studying a permanent solution.

#4 Updated by Andrea Dell'Amico over 1 year ago

A couple of possible solutions:

One of the proposals in the second thread is much easier to implement than the first one, but it's also less elegant.

#5 Updated by Andrea Dell'Amico over 1 year ago

  • Status changed from New to In Progress

I'm implementing the following option: the docker demon will be restarted just after the iptables service. No container is going to be affected.

#6 Updated by Andrea Dell'Amico over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Feedback

I have a fix that I'm going to test at the next service reconfiguration.

#7 Updated by Andrea Dell'Amico over 1 year ago

  • Status changed from Feedback to Closed

Successfully tested.

Also available in: Atom PDF