Project Task #11287

Project WP #641: WP5 - Supporting Blue Assessment: VREs Development [Months: 1-30]

Project Task #642: T5.1 Stock Assessment VRE [Months: 1-30]

Project Activity #1674: VRE Stock Assessment Workplan

Project Activity #5135: WECAFC-FIRMS

Project Activity #11214: WECAFC-FIRMS data / map dissemination tools

WECAFC-FIRMS - Compute & Provide reference spatial shapefile(s) for upload in DB

Added by Emmanuel Blondel over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:Feb 22, 2018
Priority:HighDue date:
Assignee:Emmanuel Blondel% Done:

100%

Sprint:WP05
Lead beneficiary:5 - FAO Participants:11 - CITE, 5 - FAO
Milestones:
Duration:

Description

As agreed with @yann.laurent@fao.org this spatial shapefile will correspond to the intersect of WECAFC region with EEZs. Possibly 2 shapefiles will be provided: 1 conserving EEZ native boundaries (even if extend beyond the strict WECAFC region boundaries), 1 cutting EEZ native boundaries.

Additional shapefiles may be shared later if they need to be uploaded into Postgres/Postgis

For integration the command shp2pgsql can be used Here some hints how to use it: http://suite.opengeo.org/docs/latest/dataadmin/pgGettingStarted/shp2pgsql.html

eez_intersect.zip - eez_intersect (657 KB) Emmanuel Blondel, Feb 23, 2018 12:19 AM

eez_overlap.zip - eez_overlap (1.17 MB) Emmanuel Blondel, Feb 23, 2018 12:19 AM

eez_overlap_strict.zip - eez_overlap_strict (900 KB) Emmanuel Blondel, Feb 23, 2018 12:19 AM

History

#1 Updated by Kostas Kakaletris over 1 year ago

After installing postgis and contrib packages the shp2pgsql is installed on preproduction server.

When the shape files to be imported are ready we will verify the parameters for the import.

#2 Updated by Emmanuel Blondel over 1 year ago

Dear @k.kakaletris@cite.gr see attached 3 zipped shapefiles I would need to have imported in the DB. They are 3 different because they are variant that I will possibly have to handle for mapping purpose. Thanks in advance for uploading them (with the same names as the shapefiles). In case of issue, let me know

#3 Updated by Kostas Kakaletris over 1 year ago

  • % Done changed from 50 to 80

I uploaded the shape files.
I had the following issue with encoding.

Unable to convert data value to UTF-8 (iconv reports "Invalid or incomplete multibyte or wide character"). Current encoding is "UTF-8". Try "LATIN1" (Western European), or one of the values described at http://www.postgresql.org/docs/current/static/multibyte.html.

I used the -W "latin1" parameter and seems to worked. I added the three shapefiles and the tables are :
eez_intersect
eez_overlap_strict
eez_overlap

Tested the read only and user can execute select statement on them.

#4 Updated by Emmanuel Blondel over 1 year ago

Thank you for your support. I'm not suprised you had to do this, ESRI shapefile is not handling well UTF-8 (behind the scene fields attribute data is in DBase format!...), and given special characters (the case here probably), we sometimes have to go through Latin-1 encoding at DB level when importing shapes.

For a complete feedback and closing the ticket, I will need to wait a bit that I try the configuration of these GIS resources through geoserver (see related ticket), hopefully soon as the components are yet under deployment by CNR.

#5 Updated by Emmanuel Blondel over 1 year ago

  • % Done changed from 80 to 100
  • Status changed from In Progress to Closed

I've tested retrieval of the above layers through R and they are well configured. As highlighted in #11216, i need a JNDI config set-up on the databases (pre-production & prod), so I can connect Geoserver to them.

Also available in: Atom PDF