Bug #11228

Courses Manager: editing the course metadata in the manager app is not reflected in the student view

Added by Massimiliano Assante almost 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:Feb 20, 2018
Priority:UrgentDue date:Feb 28, 2018
Assignee:Francesco Mangiacrapa% Done:

100%

Category:-
Sprint:zz - Unsprintable
Milestones:
Duration: 7

Description

For instance, I create a course with no description, then I add it. The students don't see it in the view single course view.

This is related to JPA

History

#1 Updated by Pasquale Pagano almost 2 years ago

  • Priority changed from Normal to Urgent

is it a bug? If yes, it is urgent to fix it.

#2 Updated by Francesco Mangiacrapa almost 2 years ago

  • Status changed from New to In Progress

#3 Updated by Francesco Mangiacrapa almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Feedback

I just fix the issue.
The problem is always linked to JPA and its objects management into Take Porltet. This last is able to load only first time the objects and then it does not update them anymore, so if an object is updated by Teacher (i.e a description of a course) it is not reflected in the student view (Take Portlet). N.B. Calling a method of the training-module-library it performs a JPA query to load the object from DB always, no cache is used.
However, I updated the method getTrainingCourse called by Take Portlet using pure java-sql query instead of JPA, this change should fix the issue.

Please @massimiliano.assante@isti.cnr.it, rebuild Take Course Porltet check the fix in dev and then close this ticket if it works fine.

#4 Updated by Massimiliano Assante almost 2 years ago

  • Status changed from Feedback to Closed

The fix works in dev, it can be released in 4.11

Also available in: Atom PDF