Task #11034

VRE #10759: Request for a VRE for french tropical tuna fisheries data

French tropical tuna atlas VRE - new PostgreSQL database "tunaatlas_france"

Added by Paul Taconet over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:Jan 24, 2018
Priority:NormalDue date:
Assignee:_InfraScience Systems Engineer% Done:

100%

Category:-
Sprint:WP08
Infrastructure:Production
Milestones:
Duration:

Description

Related to the ticket #10759 , we would like an empty database (PostgreSQL + PostGIS) for the new VRE French tropical tuna atlas.

The specifications for the database to deploy are below:

  • The database should be named "tunaatlas_france".
  • PostGIS extension with postgis_topology should be enabled
  • The PostgreSQL + PostGIS versions should be the ones used in the current tunaatlas database
  • The capacity should be 100 GB
  • The database should be empty (i.e. we will deploy the model once the empty database is available)
  • There should be one role named "tunaatlas_admin" with CREATEROLE and CREATEUSER privileges

Thanks,

Paul

Capture du 2018-01-26 16_15_50.png (393 KB) Paul Taconet, Jan 26, 2018 04:18 PM

2117

History

#1 Updated by Roberto Cirillo over 1 year ago

  • Parent task set to #10759

#2 Updated by Andrea Dell'Amico over 1 year ago

@paul.taconet@ird.fr I need to know the additional user names to set up the postgresql ACLs correctly. Do you also need access from the phpPgAdmin instance? If so I'll need to add a CNAME to that server, phpPgAdmin is very old and unmaintained and I need to do some tricks to let a user connect to different databases.

#3 Updated by Paul Taconet over 1 year ago

To start I would need two users (both with USAGE privileges):
- tunaatlas_inv (access to a set of tables only)
- tunaatlas_conf (access to all the tables, i.e. both public and confidential data)

Thank you

#4 Updated by Paul Taconet over 1 year ago

Regarding phpPgAdmin, it is not necessary for now. Thanks

#5 Updated by Andrea Dell'Amico over 1 year ago

  • % Done changed from 0 to 90
  • Status changed from New to In Progress

#9 Updated by Andrea Dell'Amico over 1 year ago

Hm. There was an error in the pg_hba.conf file, so the reload was failing. It should be OK now.

#10 Updated by Paul Taconet over 1 year ago

ok, sorry I did not save the pw. Can you give it to me again?

#12 Updated by Paul Taconet over 1 year ago

Thanks
I have saved the pw and tried to connect: it's working!
I will do some tests for the users next week.
Thanks a lot,
Paul

#13 Updated by Andrea Dell'Amico over 1 year ago

  • % Done changed from 90 to 100
  • Status changed from In Progress to Feedback

#14 Updated by Andrea Dell'Amico over 1 year ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF