Task #10890

Randomly logged out from RStudio

Added by Julien Barde over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:Jan 12, 2018
Priority:HighDue date:
Assignee:_InfraScience Systems Engineer% Done:

80%

Category:Default
Sprint:WP08
Infrastructure:Development
Milestones:
Duration:

Description

As I explained in #10881, like @taha.imzilen@ird.fr but in RStudiolab VRE with this URL http://ip-90-147-167-220.ct1.garrservices.it/, RStudio server closes by itself multiple times a day. Chloé Dalleau has the same problem.

Capture d_écran de 2018-02-21 09-07-30.png (257 KB) Julien Barde, Feb 21, 2018 09:08 AM

2191

Related issues

Related to BlueBRIDGE - Support #11305: Issues with RStudio (http://ip-90-147-167-220.ct1.garrser... Closed Feb 26, 2018
Related to D4Science Infrastructure - Task #11313: Activate a LDAP slave at the GARR facility Closed Feb 27, 2018

History

#1 Updated by Andrea Dell'Amico over 1 year ago

  • Parent task deleted (#10881)
  • Status changed from New to In Progress

#2 Updated by Andrea Dell'Amico over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Feedback

There were old processes that still used memory and cpu resources. I cleaned them up, let me know if the service works reliably now.

#3 Updated by Julien Barde over 1 year ago

  • Status changed from Feedback to Closed

Thanks @andrea.dellamico@isti.cnr.it, I closed the ticket and will re open it if we still have the same issue

#4 Updated by Julien Barde over 1 year ago

  • Status changed from Closed to In Progress

I reopened the ticket since we face the same issue again

#5 Updated by Roberto Cirillo over 1 year ago

  • Assignee changed from Andrea Dell'Amico to Julien Barde
  • Status changed from In Progress to Feedback

I've checked right now your user on RStudioLab VRE (as explained in #10881) and it seems to be properly connected to the rstudio instance (http://ip-90-147-167-220.ct1.garrservices.it/).

Please, could you add the user and the VRE where you have facing this issue?

#6 Updated by Julien Barde over 1 year ago

Yes this is the case at least for me and Chloé Dalleau when using RStudioLab VRE and related RStudio (http://ip-90-147-167-220.ct1.garrservices.it/)
It happened a lot yesterday and today still. Please tell us if it's the same situation for other VREs ans RStudio instances...

#7 Updated by Roberto Cirillo over 1 year ago

@julien.barde@ird.fr, please, could you try to open a fresh browser window and retry?
I've checked the instance (http://ip-90-147-167-220.ct1.garrservices.it/) with your user and it seems to work properly.

#8 Updated by Pasquale Pagano over 1 year ago

  • Status changed from Feedback to Closed
  • Tracker changed from Support to Task

It is really not acceptable that a ticket remains for 29 days in feedback status. Please put more attention on those tickets and close them asap next time.

#9 Updated by Julien Barde over 1 year ago

I am very sorry for the incovenience.
Howevever the situation is not fixed. The problem remains the same and we don't have time to write (or re-open) a ticket every time Rstudio logs out.

#10 Updated by Julien Barde over 1 year ago

As I explained the problem is not fixed. I faced the same issue during the workshop in Montpellier 10 days agos.
@anne.elise.nieblas@gmail.com still get disconnected today and I am sure the situation is the same for other users.
I let you decide whether or not this ticket should be re-opened.

#11 Updated by Andrea Dell'Amico over 1 year ago

  • % Done changed from 100 to 80
  • Status changed from Closed to In Progress

Sorry @julien.barde@ird.fr is that still happening on ip-90-147-167-220.ct1.garrservices.it or on other instances?

#12 Updated by Andrea Dell'Amico over 1 year ago

  • Assignee changed from Julien Barde to _InfraScience Systems Engineer

#13 Updated by Julien Barde over 1 year ago

I have been disconnected using http://ip-90-147-166-171.ct1.garrservices.it/ (from SDI VRE)
@anne.elise.nieblas@gmail.com (correct me if I am wrong) is using IOTC SS3 VRE which share the same RStudio instance.

#14 Updated by Julien Barde over 1 year ago

I just tried Rstudio lab VRE and had the same issue :http://ip-90-147-167-220.ct1.garrservices.it/r-connector/gcube/service/disconnect

#15 Updated by Andrea Dell'Amico over 1 year ago

There were active session processes of yours on both the servers, started yesterday night. I killed them and cleaned up your .rstudio directory. Can you check if that helps?
We are working to intercept the problems you encounter, but there's no useful hint from the rstudio server status: from its point of view, it seems that all is working correctly.

#16 Updated by Julien Barde over 1 year ago

Thanks.
I will check if it's stable. FYI, I lost the different tabs which were open before (see attache screenshot), can you restore them (no worries if not) ?

#17 Updated by Julien Barde over 1 year ago

Additional information: yesterday, @taha.imzilen@ird.fr and chloe.dalleau@ird.fr had the same problem with http://ip-90-147-166-181.ct1.garrservices.it/ but nothing to declare today.

#18 Updated by Anne Elise Nieblas over 1 year ago

Hello, I have been getting logged out randomly and the Rstudio window closes by itself (most recent event was about 5 min ago). I'm also finding today that Rstudio is really slow, it will stop printing values to the console, and then it won't launch any further commands until I restart the session. I'm using the IOTC_SS3 Rstudio instance http://ip-90-147-166-173.ct1.garrservices.it/
Thanks

#19 Updated by Andrea Dell'Amico over 1 year ago

Julien Barde wrote:

Thanks.
I will check if it's stable. FYI, I lost the different tabs which were open before (see attache screenshot), can you restore them (no worries if not) ?

Sorry, the only way to restore the ability to login is to remove the old session records

Hello, I have been getting logged out randomly and the Rstudio window closes by itself (most recent event was about 5 min ago). I'm also finding today that Rstudio is really slow, it will stop printing values to the console, and then it won't launch any further commands until I restart the session. I'm using the IOTC_SS3 Rstudio instance http://ip-90-147-166-173.ct1.garrservices.it/

I just restarted the rstudio server. I see that you have a session running, can you close and open it again?

#20 Updated by Julien Barde over 1 year ago

Yes it's done: I just restarted my session.

#21 Updated by Anne Elise Nieblas over 1 year ago

yes, me too. my session has been closed and restarted, and the tab closed by itself just a minute ago

#22 Updated by TAHA IMZILEN over 1 year ago

Hello,
I have been getting logged out randomly several time this morning and Nothing works properly.
I can not even leave the session and open a new one.
Thanks

#23 Updated by Julien Barde over 1 year ago

this problem is already reported here #11305

#24 Updated by Andrea Dell'Amico over 1 year ago

  • Related to Support #11305: Issues with RStudio (http://ip-90-147-167-220.ct1.garrservices.it/) added

#25 Updated by Andrea Dell'Amico over 1 year ago

I've just restarted the rstudio service on the instance where @taha.imzilen@ird.fr has an active session.

#26 Updated by Andrea Dell'Amico over 1 year ago

  • Related to Task #11313: Activate a LDAP slave at the GARR facility added

#27 Updated by Julien Barde over 1 year ago

  • Status changed from In Progress to Closed

RStudio seams stable now. I close the ticket and we will re-open it if needed.
Thanks.

Also available in: Atom PDF