SW Test #10844

SW Test #10728: gCube Release 4.10.0 FT Testing

SW Test #10841: org.gcube.portlet-user.4-10-0

org.gcube.portlets-user.simul-fish-growth-portlet.1.6.0

Added by Maria Di Girolamo over 1 year ago. Updated over 1 year ago.

Status:Tested on PreprodStart date:Jan 22, 2018
Priority:NormalDue date:Jan 26, 2018
Assignee:Maria Di Girolamo% Done:

100%

Category:portlets-user
Sprint:Release 4.10.0 - FT Testing
Milestones:
Duration: 5

NotSAveUploadedFiles.png (143 KB) Maria Di Girolamo, Jan 23, 2018 05:32 PM

2094

Related issues

Related to gCube - Release #10820: org.gcube.portlets-user.simul-fish-growth-portlet.1.6.0 Released Jan 03, 2018

History

#1 Updated by Maria Di Girolamo over 1 year ago

  • Related to Release #10820: org.gcube.portlets-user.simul-fish-growth-portlet.1.6.0 added

#2 Updated by Maria Di Girolamo over 1 year ago

  • Start date changed from Jan 09, 2018 to Jan 22, 2018
  • Due date set to Jan 26, 2018

#3 Updated by Denis Pyriochos over 1 year ago

Let me point that the test steps remain the same as only a string modified (the message of the News Feed post).

#4 Updated by Massimiliano Assante over 1 year ago

Denis, the portlet has been updated on preprod. If no changes are required in the service the testing can start I suppose @roberto.cirillo@isti.cnr.it ?

#5 Updated by Denis Pyriochos over 1 year ago

Hey @massimiliano.assante@isti.cnr.it thanks for the swift deploy :)
The testing could start but would you let us test it first so we can catch probable glitches?

#6 Updated by Roberto Cirillo over 1 year ago

Massimiliano Assante wrote:

Denis, the portlet has been updated on preprod. If no changes are required in the service the testing can start I suppose @roberto.cirillo@isti.cnr.it ?

The portlet and the service are both communityApp components.
The deadline for communityApps integration is planned for 19/01/2018 (Friday) so there is still time to release the service. I suggest to wait until the deadline.

#7 Updated by Denis Pyriochos over 1 year ago

@massimiliano.assante@isti.cnr.it and @roberto.cirillo@isti.cnr.it there is no service update, just a minor portlet tweak. So we hope that this will be a "lazy" deploy for us :)

#8 Updated by Denis Pyriochos over 1 year ago

The portlet is ready and testable. So the tester (@mariaantonietta.digirolamo@eng.it ?) may perform it even before 26/1, if that suits her.

#9 Updated by Maria Di Girolamo over 1 year ago

  • Status changed from New to Under Testing

#10 Updated by Maria Di Girolamo over 1 year ago

HIi @denispyr@i2s.gr ,
the test plan is the same of the last release?

Thank you,
Maria.

#11 Updated by Maria Di Girolamo over 1 year ago

  • Status changed from Under Testing to Available

#12 Updated by Maria Di Girolamo over 1 year ago

  • % Done changed from 0 to 10
  • Assignee changed from Maria Di Girolamo to Denis Pyriochos
  • Status changed from Available to Test Issue
  • File NotSAveUploadedFiles.png added

The model is not created because it's no possible saving the file uploaded (proper_sampling.xls and proper_weight_categories) , an error is provided as reported in the file attached.

#13 Updated by Denis Pyriochos over 1 year ago

Guessing a Home Library issue. I reported it at #11026.

#14 Updated by Maria Di Girolamo over 1 year ago

  • Status changed from Test Issue to Under Testing

#15 Updated by Maria Di Girolamo over 1 year ago

  • % Done changed from 10 to 90
  • Status changed from Under Testing to Test Issue

Hi @denispyr@i2s.gr , the portlet seems work fine excep for the step3.

The model is created and the messge sent in inbox.
But when another user (for example mister pink or my user) try to open the link https://pre.d4science.org/group/prevre/what-if?p_p_id=simul_WAR_simulfishgrowthportlet&p_p_lifecycle=0 , the model created is not in the list (in this case mister orange created propermodel_again_new_1000).

The link Techno Economic Investment Analysis at https://pre.d4science.org/group/prevre/techno-eco-analysis?p_p_id=TechnoEconomicAnalysisPortlet_WAR_technoeconomicanalysisportlet&p_p_lifecycle=0 is correct and the user can create the analysis.

Please, let me know if I wrong something ,
Thank you
Maria.

#16 Updated by Denis Pyriochos over 1 year ago

  • Status changed from Test Issue to Available

No @mariaantonietta.digirolamo@eng.it, this is the correct behavior. It takes he user to the "What-if analysis" list (*) because the created/updated model could be used in an analysis (create a new one, update on old one, etc).

(*) NOT in the Models list

#17 Updated by Maria Di Girolamo over 1 year ago

  • % Done changed from 90 to 100
  • Assignee changed from Denis Pyriochos to Maria Di Girolamo
  • Status changed from Available to Tested on Preprod

Thank you @denispyr@i2s.gr for your clarification.
The portlet seems work fine. The results are available at: https://goo.gl/AHFrWk.

Also available in: Atom PDF