Incident #10716

gCube Releases portlet showing Release has been archived and is not accessible anymore

Added by Massimiliano Assante almost 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:Dec 15, 2017
Priority:UrgentDue date:
Assignee:Massimiliano Assante% Done:

100%

Category:-
Infrastructure:Production
Milestones:
Duration:

Description

When I go to https://dev.d4science.org/docs it is not possible to access the artifacts anymore.

It shows the notes and a message saying "Release has been archived and is not accessible anymore" but it should not AFAIK.

History

#1 Updated by Francesco Mangiacrapa almost 2 years ago

  • Assignee changed from Francesco Mangiacrapa to Massimiliano Assante
  • Status changed from New to In Progress

The problem is due to failing on setting context (the production SCOPE is missing). In particular is failing the following code:

try{
            ScopeHelper.setContext(request, ScopeHelper.USERNAME_ATTRIBUTE);
        }catch(Exception e){
            _log.error("Skipping error on set Context: "+ e.getMessage());
        }

The logs server-side are:
https://support.d4science.org/pastes/39

Since the scope remains null, the portlet runs in Testing Mode using the dev DB (instead of the production).

I'm going to assign the ticket to Massimiliano. Please, @massimiliano.assante@isti.cnr.it checks why it is happening

#2 Updated by Pasquale Pagano almost 2 years ago

  • Priority changed from Normal to Urgent

#3 Updated by Massimiliano Assante almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF