Feature #10488

Public projects do not show up to all users in geoanalytics platform

Added by Dimitris Katris about 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:Nov 30, 2017
Priority:NormalDue date:
Assignee:Dimitris Katris% Done:

100%

Category:geoanalytics
Sprint:zz - UnSprintable
Milestones:
Duration:

Description

If a user creates a public project it doesn't show up to the rest of the users. The purpose of public projects is exactly that. Can you please fix the issue?


Related issues

Related to gCube - Release #10492: org.gcube.geoanalytics.geoanalytics.2.5.1 Released Nov 13, 2017
Related to gCube - SW Test #10490: [DUPLICATED]org.gcube.portlets-user.geoanalytics-portlet.... Tested on Preprod Nov 30, 2017 Nov 30, 2017
Related to gCube - SW Test #10379: org.gcube.portlets-user.geoanalytics-portlet.1-7-0 Tested on Preprod Nov 20, 2017 Nov 28, 2017

History

#1 Updated by Dimitris Katris about 2 years ago

  • Description updated (diff)

#2 Updated by Dimitris Katris about 2 years ago

  • Status changed from New to In Progress

#3 Updated by Maria Di Girolamo about 2 years ago

Hi all, if the scope of the pubblic project is that all individuals of the same organization (for example preVRE) can be showed it , than it's necessary to add this step in the test plan.

Thank you
Maria.

#4 Updated by Maria Di Girolamo about 2 years ago

  • Related to SW Test #10490: [DUPLICATED]org.gcube.portlets-user.geoanalytics-portlet.1-7-0 added

#5 Updated by Dimitris Katris about 2 years ago

Yes @mariaantonietta.digirolamo@eng.it we agree. This is something that should also be specified in the test plan. @vfloros@cite.gr can you please add it?

Furthermore, now that we have applied the fix in the code, @mariaantonietta.digirolamo@eng.it, can you please help us by specifying which is the procedure that we should follow in order to apply this fix in the production VRE?

For example, shall we create a new configuration?

Thank you in advance.

#6 Updated by Maria Di Girolamo about 2 years ago

We have 3 option:
1) We could add in the new release 4.9.0 a new configuration, because it's a bug no incident (correct me if I wrong). Or
2) Open a maintenance release 4.8.1 and deploy in production VRE
3) integrate in the release 4.8.0 (it open yet) and deploy in production : remember it's necessary to deploy in Nexus both gCube Staging and Release to maintain alignment of the two repository for the release 4.8.0.

At the moment I think it's better to integrate in the release 4.8.0.

#7 Updated by Dimitris Katris about 2 years ago

Nice! @vfloros@cite.gr can you continue with the third option please?

#8 Updated by Vassilis Floros about 2 years ago

Yes, I will do so.

#9 Updated by Maria Di Girolamo about 2 years ago

  • Related to Release #10492: org.gcube.geoanalytics.geoanalytics.2.5.1 added

#10 Updated by Vassilis Floros about 2 years ago

@k.kakaletris@cite.gr can you please redeploy the service both in the pre-production and production?
You can find the build here:
http://etics.esl.eng.it/etics-repository-ws/reports/id/82a48c53-0736-4c98-b2da-958602d28e4e/centos6.9_x86_64_gcc447/-/reports/build-status.xml

@massimiliano.assante@isti.cnr.it FYI we are doing an upgrade to fix the bug described in the current ticket.

#11 Updated by Kostas Kakaletris about 2 years ago

@vfloros@cite.gr the service was redeployed both in the pre-production and production.

#12 Updated by Vassilis Floros about 2 years ago

Thank you.

#13 Updated by Vassilis Floros about 2 years ago

  • Assignee changed from Vassilis Floros to Dimitris Katris

The portlet was tested again in the preproduction and it performs according to the testing plan.

#14 Updated by Pasquale Pagano almost 2 years ago

  • Tracker changed from Bug to Feature

I am changing the tracker since this issue was not properly managed. Please close it if possible and otherwise report on the work you are doing to fix it.

#15 Updated by Dimitris Katris almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

#16 Updated by Maria Di Girolamo almost 2 years ago

  • Related to deleted (SW Test #10490: [DUPLICATED]org.gcube.portlets-user.geoanalytics-portlet.1-7-0)

#17 Updated by Maria Di Girolamo almost 2 years ago

  • Related to SW Test #10490: [DUPLICATED]org.gcube.portlets-user.geoanalytics-portlet.1-7-0 added

#18 Updated by Maria Di Girolamo almost 2 years ago

  • Related to SW Test #10379: org.gcube.portlets-user.geoanalytics-portlet.1-7-0 added

Also available in: Atom PDF