Support #10295

VRE #7450: request for a VRE for IOTC working party (octobre / november 2017) : IOTC SS3 VRE

Issue with the Workspace path

Added by Julien Barde over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:Nov 10, 2017
Priority:NormalDue date:
Assignee:Anne Elise Nieblas% Done:

0%

Category:-
Sprint:WP08
Infrastructure:Production
Milestones:
Duration:

Description

I am not sure if this is a real issue or not but it's confusing for users.

See the two attached screenshots: when I click on a folder from the folder tree in the left side, the path of folder in the upper right is OK. But when I click on the same folder in the main frame, the path in the upper right is wrong

Capture d_écran de 2017-11-10 08-04-02.png (205 KB) Julien Barde, Nov 10, 2017 08:06 AM

Capture d_écran de 2017-11-10 08-07-54.png (216 KB) Julien Barde, Nov 10, 2017 08:12 AM

Screen Shot 2017-11-13 at 10.14.41.png (63.7 KB) Leonardo Candela, Nov 13, 2017 10:15 AM

ChildSubTreeRootError.png (293 KB) Anne Elise Nieblas, Nov 14, 2017 03:53 AM

ServerChildrenError.png (298 KB) Anne Elise Nieblas, Nov 14, 2017 03:56 AM

DeleteError.png (299 KB) Anne Elise Nieblas, Nov 17, 2017 06:05 AM

FolderChildrenItems.png (344 KB) Anne Elise Nieblas, Nov 17, 2017 06:08 AM

1863
1864
1879
1884
1886
1907
1908

History

#1 Updated by Leonardo Candela over 1 year ago

  • Assignee changed from Massimiliano Assante to Julien Barde
  • Status changed from New to Feedback

The fact that the breadcrump (the path appearing on top) is not always in sync with the folder displayed in the right part of the workspace is a known issue.

However, it is not happening in every interaction pattern. In particular, I'm not able to replicate the one you are reporting, i.e. whenever I click on a folder in the main panel (that appearing on the right) the breadcrump is updated accordingly ... what is not changing is the tree on the left (yet this seems to me reasonable).

I kindly ask you to clarify the steps you performed in order to have the breadcrump out of sync wrt what is on the main panel.

#2 Updated by Julien Barde over 1 year ago

It happens in here in IOTC SS3 VRE: Workspace > VRE Folders > IOTC_SS3 > ss324

I tried in Tuna Atlas and it's OK

As I said if I select my folder (eg "NetCDF") only from the tree then the path is ok. If I select the same folder from the main panel, then the path is wrong.

#3 Updated by Leonardo Candela over 1 year ago

I suspect there is something "weird" with the workspace folder associated with the IOTC SS3 VRE.

If I click on the folder in the tree panel (to see the folder content on the right panel) I can see the content correctly.

If I click on triangle of the same folder to see the structure expanded in the tree panel I see the error "Sorry, an error has occurred on the server when getting folder children items. Try again"

If I try to access the subfolder ss324 I see the error "Sorry, an error has occurred on the server when getting items for grid. Try again" ... when accessing the folder metadata I see the attached screenshot (there is a membership problem).

All in all, my feeling is saying that the problem is not the breadcrump rather it is something with that particular folder.

#4 Updated by Julien Barde over 1 year ago

Just in case it might be related: the sub-folder "NetCDF" is used by Thredds server (see details with @fabio.sinibaldi@isti.cnr.it)

#5 Updated by Costantino Perciante over 1 year ago

The issue with that folder is a known one, as reported in https://support.d4science.org/issues/7450

The problem is mainly related to the fact that it was a shared folder (among few people) moved under a VRE shared folder. The only solution we see (and I asked for a confirmation) is to delete the folder (under the VRE shared folder) and upload it again as a simple folder. This way, all vre members will have access to it, but as drawback it will be unshared from the private workspaces of people originally involved in the share.

A fix for this behaviour is going to be released in the upcoming gCube 4.8 version.

#6 Updated by Leonardo Candela over 1 year ago

  • Assignee changed from Costantino Perciante to Julien Barde

I kindly ask @julien.barde@ird.fr and/or @anne.elise.nieblas@gmail.com to perform the actions envisaged here #7450#note-29 i.e.

  • to create a new folder expected to contain the content of the current ss324 ... ss324 "current" folder is buggy for the rest of VRE Members;
  • to move (or copy) the content of the current ss324 to the new folder;
  • to remove the current ss324 from the IOTC_SS3 VRE folder.

#7 Updated by Anne Elise Nieblas over 1 year ago

Hello, I've created a new folder 'ss3' with the contents of 'ss324' copied inside, and deleted 'ss324' from the IOTC_SS3 VRE folder. Cheers, Anne-Elise

#8 Updated by Anne Elise Nieblas over 1 year ago

Hello,
I'm having an error when navigating around the new folder - VRE Folders/IOTC_SS3/ss3 - I cannot click on the link tree to go back through the folder - i.e., in the blue bar of the workspace, there are links Workspace - VRE Folders - IOTC_SS3 - ss3 ... and when I click on one of those links, I get a Child Sub Tree Root Error (screenshot attached). Also, when I try clicking through the file tree to the left of the screen, I get a similar but different error : "Sorry an error has occurred on the server when getting folder children items" (screenshot attached)
Thanks, Anne-Elise

#9 Updated by Massimiliano Assante over 1 year ago

  • Assignee changed from Julien Barde to Costantino Perciante
  • Status changed from Feedback to In Progress
  • Infrastructure Production added

#10 Updated by Costantino Perciante over 1 year ago

Anne Elise Nieblas wrote:

Hello,
I'm having an error when navigating around the new folder - VRE Folders/IOTC_SS3/ss3 - I cannot click on the link tree to go back through the folder - i.e., in the blue bar of the workspace, there are links Workspace - VRE Folders - IOTC_SS3 - ss3 ... and when I click on one of those links, I get a Child Sub Tree Root Error (screenshot attached). Also, when I try clicking through the file tree to the left of the screen, I get a similar but different error : "Sorry an error has occurred on the server when getting folder children items" (screenshot attached)
Thanks, Anne-Elise

Dear Anne, I'm investigating on it. If ss324 and ss3 have the same content, could we delete the old folder? (i.e. the one at /Workspace/VRE Folders/IOTC_SS3/ss324). Please note that this will also unshare it

#11 Updated by Roberto Cirillo over 1 year ago

  • Assignee changed from Costantino Perciante to Anne Elise Nieblas
  • Status changed from In Progress to Feedback

#12 Updated by Anne Elise Nieblas over 1 year ago

Hi,
In fact, I've tried to delete the Workspace>VRE Folders>IOTC_SS3>ss324 folder several times but I get the error: The file doesn't exist and that it may have been deleted by another user (screenshot attached), but it continues to show up in my workspace.

In other news, I was able to successfully delete the Workspace>VRE Folders>IOTC_SS3>ss3 folder, and have replaced it with a Workspace>VRE Folders>IOTC_SS3>ss3_public folder, but I have the FolderChildrenItems error again (screenshot attached).

Cheers Anne-Elise

#13 Updated by Pasquale Pagano over 1 year ago

  • Assignee changed from Anne Elise Nieblas to Costantino Perciante

Please @costantino.perciante@isti.cnr.it and/or @francesco.mangiacrapa@isti.cnr.it solve this issue. Thanks.

#14 Updated by Costantino Perciante over 1 year ago

  • Assignee changed from Costantino Perciante to Anne Elise Nieblas

Now it should work properly. I've removed the not working one.

@anne.elise.nieblas@gmail.com could you check it please?

#15 Updated by Anne Elise Nieblas over 1 year ago

Great! Yes, it works!

#16 Updated by Pasquale Pagano over 1 year ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF